Error Installing Agile Platform

Error Installing Agile Platform

Hi, Every Body...
 I am Installing Service Studio at My Laptop Using Windows 7 Home, But  After 90 % Installation I got an Error"Service Center Publish Was Not Completed"
so i have tried 3 times but same error, so any body plz help me, what to do to fix it....
Israr Ahmad... 
Hello Israr,

Have you tried installing Service Studio from an elevated command prompt?

No, i did not, and also dont know the procedure...
take a point, i am installing Agile Platform 6, not only Service Studio......

Israr, yes, all installed off the same install file.

To run the elevated command prompt
1. Goto Start | All Programs | Accessories and right click on 'Command Prompt' and select 'Run as administrator'
2. In the command prompt, you will now need to navigate to the folder where you have saved 'Outsystems-AgilePlatform-Full-Setup.exe'
3. Now simply type 'Outsystems-AgilePlatform-Full-Setup.exe' (without inverted commas) and it should work!


Hi Israr,

Im assuming you have a Windows 7 Home Premium, since the server is not supported on Home Basic due to IIS limitations in that edition.
Did you submit the feedback from your installation?

Can you try to access http://localhost/ServiceCenter/ ?
And post  the details of the error?

João Rosado
Dear Jao Rosado...

when i type http:\\localhost\CerviceCenter\
This Error Comes.

HTTP Error 500.19 - Internal Server Error

The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information
Module IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x80070021
Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File \\?\C:\Program Files\OutSystems\Platform Server\running\ServiceCenter.01149560379\web.config
Requested URL http://localhost:80/ServiceCenter/
Physical Path C:\Program Files\OutSystems\Platform Server\running\ServiceCenter.01149560379\
Logon Method Not yet determined
Logon User Not yet determined
Hi Israr,

That seems to be a problem with the windows version. Can you confirm that it's not Windows Home Basic?
The platform server is not supported in Windows Home Basic. 

From the download page:

"System Requirements: Windows XP Professional (SP2 or later), Windows Server 2003 (SP1 or later) or 2008 R2, Windows Vista or 7 (Home Premium, Business, Enterprise or Ultimate), Internet Explorer 7 or 8, Microsoft .Net Framework 3.5 (will be installed by the platform if not present) and a Pentium IV-compatible 2GHz processor, 500 Mb of disk space and 2 Gb of RAM."

João Rosado
yup i am using Windows 7 Home Basic...
thanxxxxxxxx so much for the help.....
Hello guys, I am having the same issue here. While trying to install "OutSystems-AgilePlatform-Full-Setup." at the end I got this message "Service Center Publish Was Not Completed".

Using Windows 7 pro edtion. Please any suggestions...
Khalid Mohamed wrote:
Hello guys, I am having the same issue here. While trying to install "OutSystems-AgilePlatform-Full-Setup." at the end I got this message "Service Center Publish Was Not Completed".

Using Windows 7 pro edtion. Please any suggestions...
 Hi Khalid,

If your Windows language is not English, you may be hitting this known bug:

Have a look at the logs and let us know if it's the same error.


Thank you Miguel for the link, but it is not the case. My system set to United State, English.

Here the story:

I was using Agile platform, then when I had some trouble with an application. I just uninstalled the platform. Since then I am trying to re install a fresh copy of it, but nothing works every time the same message keep popping up.

I disconnected the internet, and done the installation once more, guess what it worked this time.

Then I just re updated the license file, and now everything is cool.

Simply, the issue was related to the "Service Center" unable to be published, and you won't have the chance to update your license file.
So, without the internet, you will be able to continue the installation, then update your license.


Hi Khalid,

I'm glad you were able to work around your problem. Still, what you describe sounds quite odd to me: I will talk to our product support team and see if they are aware of this scenario and gain some insight into it.

Many thanks,


This sort of thing used to be a problem in 5.1....

The very last update - Always re-boot the machine after install, but before running SCINSTALL.bat has not failed me to date.