Android App Generation Fails for MABS Veriosn 8.0

While we are trying to generate android application for MABS version 8.0.

App generation Failed with following log. Please note we have updated the Cordova plugins As per outsystems recommendations.

[2022-02-16T09:08:34.969Z] [ERROR] [Build] FAILURE: Build failed with an exception.

[2022-02-16T09:08:34.969Z] [ERROR] [Build] * What went wrong:

[2022-02-16T09:08:34.969Z] [ERROR] [Build] Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.

[2022-02-16T09:08:34.969Z] [ERROR] [Build] > Failed to install the following SDK components:

[2022-02-16T09:08:34.969Z] [ERROR] [Build]       platforms;android-29 Android SDK Platform 29

[2022-02-16T09:08:34.969Z] [ERROR] [Build]   The SDK directory is not writable (/opt/android-sdk)

[2022-02-16T09:08:34.969Z] [ERROR] [Build] * Try:

[2022-02-16T09:08:34.969Z] [ERROR] [Build] Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

[2022-02-16T09:08:34.969Z] [ERROR] [Build] * Get more help at https://help.gradle.org

[2022-02-16T09:08:34.969Z] [ERROR] [Build] BUILD FAILED in 31s

[2022-02-16T09:08:34.969Z] [ERROR] [Build] Command failed with exit code 1: source/platforms/android/gradlew cdvBuildDebug -b source/platforms/android/build.gradle --parallel

[2022-02-16T09:08:34.969Z] [ERROR] [Build] Build failed with the following error: Something happened on our side while generating your app. Please try again.

Hi Saravana,

Could you please share the log file for better understanding.?

As you have selected the MABS 8.0, there is a possibilities , you are using the third party/in house plugin, that is in lower version of MABS 8.0.

Please check if you have upgraded all the supported plugin used in the application as recommended by Outsystems..


Dileep

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.