When SSL is enabled for an application, 

1) Can I set SSL in IIS and that is it? OR
2) do I need to set HTTP security to SSL for all web screens or just need to set SSL for the webscreenflow only?
Hi Robert,

1) Yes, you just need to get and install certificate. In that case both http and https will work. If you wish you can also disable port 80 http in IIS or in the firewall.
2) If you wish to have https in just some webscreens or webflows you can set it at that level. The Agile Platform wil generate the link urls accordingly i.e. when jumping form an unsecure page to a secure page the url will not be relative but absolute to include the protocol. (This is usaully a big pain in other frameworks and platforms)

Tiago Simões

By the way, when SSL is enabled in IIS, ServiceCenter and ServiceStudio is no longer able to publish an eSpace.

ServiceStudio tries to ping the eSpace but it fails, and then the publication fails! 

Platform version

Is this normal behaviour? 1-click publish feature does not work when SSL is enabled?
Hi Robert,

Thanks for the feedback. That issue in 6.0 had already been identified and fixed, and the with next revision that will work correctly. Publishing in Service Center should work alright in your version, though. Do you have any problems with it?

Tiago Simões
Last attempt at publishing on an SSL enaled eSpace in failed in both ServiceStudio and ServiceCenter.

Please verify this, try enable an eSpace with SSL and republish the eSpace, see if it works,

Hi Robert,

What did you configure exactly?

In there are problems connecting Service Studio to servers with the http binding disabled, that will be fixed in the next release.
Even with that fix, if it still a requirement that the IIS is configured to accept http local connections (in

If your eSpace has screens or flows configured with HTTP Security to SSL, means those screens will only be available only in https, instead of the both protocols.
Setting the configuration at the flow level is enough.

João Rosado

Configured the virtual directory and forced it to use SSL, and since the agile platform requires the publication failed.

ServiceStudio was trying to ping the application,but it didn't work, it kept on failing on

Hi Robert,

Yup that is the expected, you cant force the virtual directories or even the website to refuse the connections on
Just configure the SSL in the webflows and everything will work fine.

João Rosado
Hi guys,

I am developing an application that uses SSL. I have put the SSL in all the webflows. Is there any way to when a user goes to the URL and puts http instead of https to automatically redirect it to https again, without getting the error «HTTPS connection required for this screen»?


Best Reggards,