insert Datetime from calendar input

I want to insert date and time , 

when i update database column from date to datetime it allows me to insert time but it give error on Seconds input and  as shown below.

 


Hello Mohammed Abdul Muqeet,

As per your screenshot its seems your calendar is working for AM and PM so you need to give that thing as well
outsystems datatime work on the local machine datatime format Due to this for

Agno Silveira and Mostafa Othman they both is not getting error because same thing due to I am sure there local machine datetime format is 24 hours and in your case its 12 hours so you need to give AM,PM

As I also check with 24 hours and 12 hours scenario you must need to Give AM PM if your local machine format for 12 hours instead of 24

For reference i have added Screenshot so I am also getting error if I don't mention AM/PM





surely,this will helps you..


Thanks and Regards,


Akshay Deshpande

Yes you are right with AM PM its working fine. 


How can i fix time with 24 format

glad to hear its working..

Please marked as solution so if anyone facing same issue they will easily come to know for solution

to Convert from 12 hours to 24 hours you don't need to anything in service studio just change in local machine go to the time and date setting from that you can change the format

Please check this link to change 12hours to 24 hours and vice versa 

Thanks and Regards,

Akshay Deshpande

I changed the machine time to 24 format but it is still in Am PM format, 



Try with restart Local machine because it will definitely reflect if you set to 24 hours then automatically AM/PM field will invisible in Browser as well as service studio check below Screenshot if you still concern Private message me  there only two field available as I highlight that hh:mm (am/pm is invisible )

(try to change with long time as well for format below short time long time is present ,not sure about this )

mvp_badge
MVP

Hello Mohammed ,

Can you share your .oml for analysis?

Regards.

Dear i have attached a test oml

datetime.oml

mvp_badge
MVP

Right, in this .oml I didn't find any problems, is saving and editing correctly.

Try deleting your input component for the Attendance Date field, and dragging and dropping the field onto the screen again.

if it doesn't work, give us more details.

Regards.

Hi Mohammed,

I tried application you shared and its working fine. I am able to select date and time then click save without any errors.

In case you need to select date only from date picker change type of datetime input to date as well as database column in this case no need for saving time.


If you have a specific scenario please explain it to me

Hello Mohammed Abdul Muqeet,

As per your screenshot its seems your calendar is working for AM and PM so you need to give that thing as well
outsystems datatime work on the local machine datatime format Due to this for

Agno Silveira and Mostafa Othman they both is not getting error because same thing due to I am sure there local machine datetime format is 24 hours and in your case its 12 hours so you need to give AM,PM

As I also check with 24 hours and 12 hours scenario you must need to Give AM PM if your local machine format for 12 hours instead of 24

For reference i have added Screenshot so I am also getting error if I don't mention AM/PM





surely,this will helps you..


Thanks and Regards,


Akshay Deshpande

Yes you are right with AM PM its working fine. 


How can i fix time with 24 format

glad to hear its working..

Please marked as solution so if anyone facing same issue they will easily come to know for solution

to Convert from 12 hours to 24 hours you don't need to anything in service studio just change in local machine go to the time and date setting from that you can change the format

Please check this link to change 12hours to 24 hours and vice versa 

Thanks and Regards,

Akshay Deshpande

I changed the machine time to 24 format but it is still in Am PM format, 



Try with restart Local machine because it will definitely reflect if you set to 24 hours then automatically AM/PM field will invisible in Browser as well as service studio check below Screenshot if you still concern Private message me  there only two field available as I highlight that hh:mm (am/pm is invisible )

(try to change with long time as well for format below short time long time is present ,not sure about this )

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.