"An operations error occurred" upon using ActiveDirectory_GetAccountDetails

Hi everyone,

We're trying to implement the Active Directory in our login. The Active Directory was already set in the Authentication on the User module, the domain was also provided. As we do our testing, we're able to validate our test user by using the ActiveDirectory_ValidateLogin action under Authentication extension. But when we try to use the ActiveDirectory_GetAccountDetails action to fetch some user data, we've encounter this error "An operations error occurred"

We're not sure what's the possible cause. Do we need to configure something to make it work?


Dear Net,
Greetings of the day

Is the above mentioned issue you are still facing ?

If still the issue is there, can you please provide details like what you are passing inside ActiveDirectory_GetAccountDetails ? Because there should be only username without domain name. 


If you are able to ValidateLogin and its working fine it means the configuration is correct.

Can you confirm the parameter value of ActiveDirectory_GetAccountDetails and check again ?

Regards,

Palak Patel

Hi Palak,


We are passing only the username in the ActiveDirectory_GetAccountDetails. It's weird because in ValidateLogin  action, it's working just fine but when we call the ActiveDirectory_GetAccountDetails action, it throws the error that I mentioned above.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.