Problem in getting base Environment specific URL

I am sending an email to User (functionality is working perfect)
and
I want to send a URL link(Not of current screen) with email content (right now URL link is hardcoded)

Please help me finding the solution (how can i get the specific Environment base URL)

Solution

Hi @Ayush Khare 

  I faced the same problem, but I solved it.

So, You need to go through the URL

https://www.outsystems.com/forums/discussion/66626/getservername-not-working/ 

I hope this will help you

Thanks, 

vednarayan



   

Hello Vednarayan,

Thanks for your help
This solution worked for my use case

Solution URL - https://www.outsystems.com/forums/discussion/66626/getservername-not-working/

Thankyou
Ayush Khare

Hi Ayush,

You can use GetRequestDomain from HTTPRequestHandler if you are sending mail from web app .

If you are sending mail from Timer than keep the environment name in site property

Best Regards

Devendra

 



Hello Devendra,

Thanks for your help
I tried this solution but GetServerName() and GetRequestDomain() both were giving null value

Thankyou
Ayush Khare

Solution

Hi @Ayush Khare 

  I faced the same problem, but I solved it.

So, You need to go through the URL

https://www.outsystems.com/forums/discussion/66626/getservername-not-working/ 

I hope this will help you

Thanks, 

vednarayan



   

Hello Vednarayan,

Thanks for your help
This solution worked for my use case

Solution URL - https://www.outsystems.com/forums/discussion/66626/getservername-not-working/

Thankyou
Ayush Khare

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.