[OfficeUtils] OfficeUtils Issue with ReplaceAdvancedTable
Service icon
Forge component by Bruno Gonçalves
Application Type

Hello, I'm facing the same issue with the word generation, especially on the table. I've followed the demo and it is working with the ReplaceText and ReplaceTable, when I tried to use ReplaceAdvancedTable, I encountered this issue.

Sequence contains no elements
at System.Linq.Enumerable.First[TSource](IEnumerable`1 source)
at OutSystems.NssOfficeUtils.CssOfficeUtils.ProcessWordTableAdvanced(RCWordAdvancedTableRecord rcWordCustomTableRecord, XWPFTable table, Object context)
at OutSystems.NssOfficeUtils.CssOfficeUtils.ProcessWordTableOutputs(RCWordFileRecord ssWordFile, XWPFTable table, List`1 TableToRemove, Object context)
at OutSystems.NssOfficeUtils.CssOfficeUtils.ProcessTable(XWPFTable table, RCWordFileRecord ssWordFile, List`1 TableToRemove, Object context)
at OutSystems.NssOfficeUtils.CssOfficeUtils.ProcessTables(IEnumerator tablesEnumerator, RCWordFileRecord ssWordFile, List`1 TableToRemove, Object context)
at OutSystems.NssOfficeUtils.CssOfficeUtils.MssGenerateWordFile(RCWordFileRecord ssWordFile, Byte[]& ssWordBinary)
at ssOfficeUtils.RssExtensionOfficeUtils.MssGenerateWordFile(HeContext heContext, IRecord inParamWordFile, Byte[]& outParamWordBinary)

This is how I do the mapping for the data :

As for how the template looks like: Am not sure if the #Starting_Point is required for the FirstPlaceholder, but after I added it and tried to use it as the starting node, I'm having that error. Table B will be a dynamic table. While A, C, and D are done by using ReplaceText.


Any feedback would be helpful.



This issue might be related with tabs in the table. In the current version there is an issue with processing them correctly.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.