Version 6 Install Issues

Version 6 Install Issues

Hello, I have built a new server in hopes of migrating from my old server running v5.0.2.48 to v6 but have a few issues when booting the machine.  I have rebuilt the new server from scratch to make sure it's clean since I ended up with a couple of other issues the first time around.  I'm thinking that since it is happening during boot that maybe the SQL Server is not ready yet and that is tripping up the Outsystems services during their startup.

Server 2003 R2 (fresh install and updates)
SQL Server 2008 R2 Express with Tools (fresh install and updates)
Agile Platform Community Edition Install using Install Checklist and help from Community Edition Install

Here are four items from the Application Log that are causing me concern:

Thank You for your assistance,
David Rickey
Hi David,

This looks to be an installation or configuration problem/quirk, that may be fairly specific to your machine.

My suggestion is that you contact OutSystems Support at with this info. Hopefully they will be able to better assist you than folks here in the forum. :)

Best regards,


Just from a straight Windows/SQL standpoint, those errors usually point to permissions issues with the SQL and application service accounts (e.g. if you are using dedicated service accounts...they don't have permissions to the required directories).  Permissions issues can be a fun thing to try to track down - especially if you have some group policies that change them on you everytime the machine is restarted.

If you are using service accounts, one thing you can do as a quick test is to change the account that the Outsystems services runs under to the "Local System" account and the SQL server accounts to "Network Service" and restart the machine.  If that works, you'll just need to make sure that the service accounts you are trying to use have full access to the application and SQL directories as required before you restore the original settings.

This might be a rabbit trail, but I hope this puts you on the right path.
Thanks guys, one thing I forgot to mention is that after the server finished booting I ran the Configuration Tool and tested all the logins/connections and all works fine.  I also did an eSpace upgrade/mirgation yesterday as well as a table data migration and had no issues, or errors in the Event log.

Also all Outsystems services are running under Local System account.

Something I tried this morning to test my theory is change the Outsystems services to Manual startup and reboot.  Once the system was back up and stable I checked the event Viewer and no issues were there.  I started the services and only the two warnings about the missing Profiler files came up.  So it appears that the Outsystems services are banging on the database before it is completely ready.  This is further verified by other (intermittent) entries in the Event log from older bootups where the hubruntime account had issues connecting but after the system finished booting everything checked out okay.

I will see if support can take a look at this thread and provide any insights.

Thanks again,
Okay peeps, just thought I'd post a followup.  After several fresh installs, both Server 2003 and Agile Platform, and trying the full installer after following the Pre-Installtion checklist, I am still getting the missing  Profiler.dat  file Warnings.  I think they are only happening when the Log Service starts so I'm not overly concerned yet since the platform seems to be working otherwise.

I contacted Support and Miguel João wasn't sure about what to do concerning the missing files but he had this to say about the SocketException errors.
  • The errors are common when the OutSystems Deployment Controller service doesn't start before the OutSystems Deployment or the OutSystems Scheduler services, or when it takes too long to initialize. Eventually, retries are automatically performed and if the services have no other errors they will recover automatically.