Error when upgrading outsystems from 9 to 10
Platform Version
10.0.1115.0

Hi,

I'm trying to upgrade outsystems eSpaces from version 9 to 10 and I'm facing this error:

Internal Error

Compilation Error.
bin\OutSystems.RESTService.Runtime.dll: error CS1705: Assembly 'OutSystems.RESTService.Runtime, Version=10.0.1115.0, Culture=neutral, PublicKeyToken=null' uses 'Newtonsoft.Json, Version=8.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed' which has a higher version than referenced assembly 'Newtonsoft.Json, Version=4.5.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed'
bin\Newtonsoft.Json.dll: (Location of symbol related to previous error)

Could anyone please help me with this

Error.jpg

For those who may be facing the same problem, I solved this error after publishing Systems Componentes


Hi.

I Already haved this error. To solve, I opened the module/library with Service Integration Studio then File > Edit Source Code With .NET.

After code opens in Visual Studio, I fix the conflits and add the missing libraries to project. Then is just save and publish the module by Service Integration.


In my case, was a migration of OS 10 to 11.

Hi @Gabriel Melo, thanks for your reply.

I don't know if i got you right. In my case the error occurs when I am publishing the eSpaces. All the extensions are Ok, there are no conflicts in them.

For those who may be facing the same problem, I solved this error after publishing Systems Componentes


Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.