Navigation issues

Navigation issues

I have a workspace that is used for tracking our applications -- config files, log files, executables, etc.  There is an entity for Applications as well as Configs, Logs, Executables.  Those all have a foreign key that points back to Applications.  I can drag the entity onto the Show Application page and the table is populated with the correct data.  If I click on the links to a popup editor (New Config, New Log, New Executable), the popup appears and when it is saved, the new item shows up in the appropriate table in the Show Application page.

Each of those tables will link back to Show page for that particular item (Show Config, Show Log, Show Executable...).  If I click on that link to navigate to that page and then I hit the back button, when I return to the Show Application page, that newly created item is no longer displayed in the table.  I have to refresh my browser and click on the "resend" warning message before they appear.

Is there any way I can force my browser (firefox) to not "forget" the newly created items?


Hi Craig

I think your best option is to add a link in each of the Show pages to navigate to the page you want, instead of relying on the browser back button.

Other option is to have the list load with the List_LateLoad widget from Richwidgets, so the page is empty at start and there is a second request to refresh it. It's a bit slower since it actually needs to do 2 requests to get you the page.

The problem is that the browser renders the initial pages html when you click th back button, and not the page after being altered by ajax requests.
You can also search on google for some javascript solutions that detect and allow to override the back button to actually click on a back link on the page. It's a bit nasty, and I would stay away from it unless really needed.

João Rosado