Visual Studio Edition to create SAP Extensions

Visual Studio Edition to create SAP Extensions

  
Hello all,

I need to create SAP Extensions within Integration Studio 6.0 to consume some BAPIs via RFC calls. According to the system requirements I must use Visual Studio 2008 (standard or higher edition). It makes any difference on choosing standard, professional or higher editions? What should I consider when choosing IDE's edition? 

Thanks in advance.

Best Regards,
Paulo Dinis
Hi Paulo,

The reason the requiment is "Standard or higher" is because the Express edition does not support addons/extensions, which is required for the SAP developement.
You can see a list with features you can check http://msdn.microsoft.com/en-us/library/zcbsd3cz%28v=vs.80%29.aspx
(Its a link for VS2005 ..but can't find the newer ones on microsoft site)

Regards,
João Rosado
Hi João,

Thanks a lot for your help. As you can see I'm trying to gather the maximum information to know which edition best suits my needs.

I've found some more information in this document Agile Platform 6.0 - Systems Requirements: "Microsoft Visual Studio 2008 Standard Edition to edit the source code of the Extension Actions.To edit SAP Wizard use higher editions than the Standard Edition of the Microsoft Visual Studio 2008".

It's not clear for me what situations require me to edit SAP wizard.


Regards,
Paulo Dinis
Hi Paulo,

Yes, unfortunately that sentence is confusing. The requirement should be Standard Edition for both cases.
That requirement and document sentence is currently requested to be reviewed.

Regards,
João Rosado
Hi João,

thank you for this valuable information.


Best Regards,
Paulo Dinis