[Test Manager] Discussion

[Test Manager] Discussion

  
Forge Component
(9)
Published on 2011-12-07 by Nuno Rodrigues
9 votes
Published on 2011-12-07 by Nuno Rodrigues
Did the download got corrupted in any manner? Trying to download it and it gives a 0 (zero) bytes download
Hello,

I have just uploaded the latest version: 1.0.1.

Thank you.
Hi,

Couple of questions:

- any quickstart guide available?
- I noticed it did something to outsystem basetables or am I wrong in that assumption?
- I have broken references to (System) after the initial 1-click publish of both osp's
- adding a case will throw an error.
Hi,
Quick answer before Nuno replies.

- No quick start available yet.
- Nothing is beeing done to outsystems basetables (os shouldn't). We are not sure what will be the behaviour in an edition other than professional (by the way, the component  as is will use ~100k S.U. - so, won't fit in a community edition).
- Could the broken references be related to the admin user? (Wild guess...)
- Related to the previous? (Wild guess again...)

--
Tiago Severina


Hello,

Clarifying the questions:

- We are working on the documentation, but the quickstart steps for the current version may be summed up as:
  1. Publish the Test_Manager and Test_Template Solutions to the appropriate environments according to role, respectively manager console and test repository;
  2. Create a common Service Center account on all repositories, for the purpose of manager access, and update the SCUserName and SCPassword Site Properties, of eSpace Test, accordingly (defaults to admin/admin);
  3. Import the test cases in the manager by searching the repository environments (this may take a few minutes, as they say...);
- Nothing is done to outsystems basetables;
- Which references on which Platform Server version are reported broken?
- An error on adding a case should be related to the above step 2. of quickstart;

Regards.
trying to install it on a clean 6.0 system and Test-espace stops on this:

I also noticed some warning with .net framework, among it are missing pdb files etc.


Hello Joost,

Test Manager has not been upgraded to version 6.0 of the Agile Platform yet, it requires version 5.1.

Having said that, the backward-compatible compilation issues were removed on the latest version, pending a proper possible future upgrade. But, to reinforce, the component does not currently work on 6.0.

Regards.

Hello,

It was noticed that the supported version status has not been updated here: The current Agile Platform version supported is 6.0, since Test Manager's version 6.0.6.

Regards.
Hi,
I tried to add the case into Test Manager. Return nothing.
Any advise?
 
Hello Aditya, you should follow the User's Manual Setup steps, and you can also check the platform Error Log.
Regards.
We set up the service, local server started (selenium), however, the test keeps showing as unknown and running. 
Could you post any additional details?

Newbie001 wrote
:
We set up the service, local server started (selenium), however, the test keeps showing as unknown and running. 
 
 
Set up is done as per user guide.
 - Started Local Server: verified selenium started as a java process
 - Configured environment: local environment
 - Created a run for the OSTemplate and WebTemplate, process show running but with the status unknow.

I have changed browser to iexplore and base is still www.google.com
Hello,

The status not updating could indicate that the Site Property ManagerAddress, of eSpace TestUnit, is set to an unaccessible address. Can you confirm that the default 127.0.0.1 is available?

Regards.

Newbie001 wrote
:
Set up is done as per user guide.
 - Started Local Server: verified selenium started as a java process
 - Configured environment: local environment
 - Created a run for the OSTemplate and WebTemplate, process show running but with the status unknow.

I have changed browser to iexplore and base is still www.google.com
 
 
Hi Nuno,

How should we encrypt the user password for Site Property "SCPassword"? We also tried a workaround to change the user password to "admin" but it doesn't allow us to use password values less than 6 chars long.

Thanks in advance.
Nuno Rodrigues wrote:
 
 
 
 Confirmed address 127.0.0.1. Moved a step further. Now there are many error in database error unable to insert (is the solution ready for version 7?)
Hi Kiki,

The password is ciphered with the platform's Encrypt built-in function.

I attach an utility espace for obtaining the ciphered text.

Regards.

kiki wrote:
Hi Nuno,

How should we encrypt the user password for Site Property "SCPassword"? We also tried a workaround to change the user password to "admin" but it doesn't allow us to use password values less than 6 chars long.

Thanks in advance.
 
 

Test Manager has not been upgraded to version 7.0 of the Agile Platform yet, it requires version 5.1 or 6.0.

We will try the upgrade soon and update its' status here.

Regards.

Newbie001 wrote:
 
 Confirmed address 127.0.0.1. Moved a step further. Now there are many error in database error unable to insert (is the solution ready for version 7?)
 
 
Hi Nuno,

Any idea why it does not update status & result upon completion of test case runs? The selenium server shows "Got result: OK,true" and "testCompleted" command is called, then the browser session is closed. Selenium logs are generated every 15 min when the timer kicks in, and if the test case runs are deleted prior to this, the Log service that the timer calls will throw SQL error (foreign key constraint violation).

Thanks in advance.

Hi Kiki,

Indeed deleting the test case run before receiving the result log will demonstrate that behaviour.

In the next few days we will publish a new and upgraded version with support for that use case.

Regards.


kiki wrote:
Hi Nuno,

Any idea why it does not update status & result upon completion of test case runs? The selenium server shows "Got result: OK,true" and "testCompleted" command is called, then the browser session is closed. Selenium logs are generated every 15 min when the timer kicks in, and if the test case runs are deleted prior to this, the Log service that the timer calls will throw SQL error (foreign key constraint violation).

Thanks in advance.
 
 
Hi Nuno,

Thank you, this is a very great news! We are definitely looking forward to the new version. By the way, just to clarify on another behavior of Test Manager:

1) While a test case is currently running, does re-publishing it completely stop its execution?
2) When a test case is scheduled to be run at a future date or interval (i.e. not currently running at the moment), does re-publishing it affect its triggering?

Thank you in advance!
Hi all,

Anybody else using Test Manager 6.0.6 would know how to locate elements inside an iframe within a test case? (xpath preferred but will appreciate other format as well) An example of this scenario is to check for <a> element existence within a RichWidget_PopupEditor.

Thanks in advance!
Hi Kiki, you can proceed as usual but you must SelectFrame() first, for changing frames to the popup frame and back. Regards.
Hi Nuno,

First of all, happy new year to you!

I have eventually ironed out the issue, it has to do with running selenium process as admin and lowering the IE browser security settings (other browsers seem to work fine). Sorry for not posting a follow-up any earlier. But I agree with your answer that SelectFrame action must be used so that the correct (i)frame can get focus/be active before we can do anything with it.

How is the new version 7 coming along, is it ready for release yet?
Hi Kiki,

Answering your questions:

1) In the Enterprise edition of the Platform it does not; test case execution is only stopped on a pool recycle;
2) It does not affect test case triggering; only if test case name or parameter name/type/order changes must the test case be reimported.

Regards.


Hi again Kiki, and a happy new year all the way through carnival and more!

As you might have noticed the release schedule has been delayed.

We have worked out version 7 upgrade but are also including a Selenium upgrade.

Regards.

 
Hi Nuno,

Good to hear from you again, and thanks for the clarification.

So far we are using Test Manager version 6 on our platform server version 7.0.1 and try to get by with somewhat limited functionalities, and we also use it with Selenium server 2.29.0 RC stand alone server.
Hi Nuno,

Just thought I'd check with you again if there is an updated version to Test Manager that you can share with us? Thanks!

BR
We aer very interested in using this one, but unfortunately, we get way too errors when compiled under 8.x. Would it be possible to provide a 8.x compatible one?

Thanks a ton in advance,
Ganesh
Hi Ganesh,

You and me are on the same boat here! My organisation had been using this app v6 on Platform v7, and found the same situation as yours when we upgraded to Platform v8 this month; currently we have to find a new testing tool urgently and re-educate the business users again.

Previously we had to make do with the old version, did few fixes by ourselves since there was no reply from Nuno for quite some time when we asked for latest update.