Unable to bootstrap excel
Application Type
Mobile

When trying to import data from an excel sheet (which previously worked perfectly) I am now getting an inexplicable error: "Excel read error in row 2: Column 'Task' has an invalid type. Expected a 'Int32' but received a 'String'"

Both the entity and the Excel structure have the column set to Text. WHY is it asking for an integer? This column has never at any point been set to integer.

VetSupport1.oml

Hi Ken,

I have published given OML in my personal environment and It is successfully Bootstrap the Tasks.xlsx.


Thanks

Vinod

Thanks Vinod

Note however that the foreign keys were not assigned by the Bootstrap method, even though the identical procedure worked before.

I played around randomly with deleting the resources and re-importing them etc. Finally got it to work without being at all clear what fixed it.

This is a problem because I need to re-import this configuration data often as my client updates it. My guess is that the excel tables on OutSystems server are not always replaced properly. Not having direct access to them or the database is a major problem for me - I'm used to developing on a lower level. Not enjoying OutSystems much and will recommend to my client not to use it.

But here is another OML that will (hopefully) work if you want to take another look.

VetSupport.oml

Hi Ken,

We can modify BootstrapTasks server action as per our requirements. 

If Task is already exist in entity then we can update it by using UpdateTask. If not exist then we can create new task.

The default implementation does not import the data in entity if records are already exist. We can change default implementation as per our needs.

Thanks

Vinod

Hi @Ken Wallace ,

1) If this i happen then please check variable holding or assigning variable type. Or you have used stricture and 2nd columns is having int. 

2) Check excel sheet column type and entity column type

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.