[InputMask React] Inserting monetary value but it sends 0 to the database.
inputmask-react
Reactive icon
Forge component by João Barata
Application Type
Reactive

Hi,

When i insert a value in the input with monetary mask it appears but when i save it says "Value = 0". I already tried this solution https://www.outsystems.com/forums/discussion/74351/mask-is-working-but-the-value-is-not-submitted-to-the-server/#Post305082  but it didn't work for me.

The thing is when I'm on Edge and it doesn't work I change to Chrome and it works (and vice versa).

Does anyone encountered this issue?


Thanks,

Tiago Pereira

Hello Tiago,

I have tried it on both browsers and the value is saved correctly on the database.

Could you possibly share your oml ? It's easier to debug the issue . 

Thank you 

Paulo Rosário

 

Hi Paulo,

Unfortunately i'm using the widget in an enterprise environment so i can't share the oml.

But it's happening sometimes and it's random, so for now what i'm telling people is that if they are using Edge to change to Chrome and vice versa and it works. I don't know if it's a widget problem or some option in the browser that disables the widget.

This are the options in the input, i had the inputs in variables so i changed them to force the direct value but it didn't change the behavior.

Thanks,

Tiago Pereira

Hello Tiago, 

It most probably is something to do with the browser, if you ever figure anything out please post here :) 

Thank you 

Paulo Rosario

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.