[OutSystems Data Grid Web] [Outsystems data grid web] Excel Export don't show the group labels on double Group
data-grid
Web icon
Forge component by Platform Maintenance
Application Type
Traditional Web
Service Studio Version
11.14.16 (Build 60354)
Platform Version
11.14.0 (Build 34092)

Hello,


I need to export to XLSX a data grid that, by default has 2 group by.

If I have only 1 group by active the label shows fine but with 2 both of them shows empty.


Thanks

Luis Sardinha


Hello @Luis Sardinha 

I'm not sure if I'm missing something but I was able to achieve that.

  1. Wen to the OutSystemsDataGridSample module available in Forge
  2. Grouped two columns
  3. Selected all elements on the Grid
  4. Clicked in Export --> Excel Export
  5. Got the expected 

Could you please provide a sample with your use case and describe the steps to reproduce?

Cheers,
GM 

Hi Gonçalo,

Thanks for your reply. 

I have a button that does the same but trying to do the same steps give me the same result.


But on my Excel (office 365) I get


Thank you

Luis Sardinha

Hello @Luis Sardinha 

On that screenshot, you're not selecting the whole Grid.
Even though, Could you please provide a sample with your use case and describe the steps to reproduce?

Cheers,
GM 


Hello Gonçalo,

I'm sory but no. 

I didn't find the solution and It's not easy to extract this to a demo application.

As soon I get an update I'll answer. 

Thank you

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.