Soap API base64Binary returns empty
Question
Service Studio Version
11.53.8 (Build 60969)

I'm having trouble on receiving a base64binary type output value from a Soap API. Other output values from this API, such as an error message, which is type string, returns with no issues.

The base64Binary is being defined on the wsdl of the API as follows:

<s:element name="GetResult" type="s:base64Binary" />


What I've tried is to change this type to binary or base 64, although it didn't work.

If I call the API outside the OutSystems the output binary is being returned with no issues.

The binary content is a pdf file.

Has anyone faced a similar issue?

Any suggestions?

If anyone else has the same issue with binary data, after some research, I have found a workaround.

On Service Studio , you have to add the file FeaturesOverride.xml , so you can enabled the creation of SOAP API with the deprecated method.

After the SOAP API has been created, you will receive binary data.

Have in mind that the workaround works with some versions of Service Studio (I tried this on 11.14.16).

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.