Traditional Carousel - List Items content in first element
Application Type
Traditional Web
Service Studio Version
11.53.6 (Build 60879)

Hello everyone!


I'm experiencing an issue with the use of the carousel widget (both from OSUIWeb and WebPatterns).

I'm placing a list inside the widget, as the carousel's content is dynamic depending on whats in the DB.

Below is an example of the widget tree layout

I have all default in the carousel, and the following in the list:

I have tried several things, however the end result is the list items all being shown vertically in the first carousel element (in the OSUIWeb widget's case), or horizontally (in the WebPatterns case), instead of 1 per slide.

I'm using the dublinTheme for reference.


Any ideas on how to address this issue?


Thank you.

The issue was, as suspected, related to the theme in use.

It was missing all the needed classes for the carousel to work properly.

Leaving this here in case someone has the same issue.


Thank you

Hello, 

You have to change the properties of list, and check the properties of carousel Widget

Also you can adjust size of image and carousel

I have implemented it and attached a oml,

please let me know if you are looking for the same

Sample Link - https://personal-ejuytnht.outsystemscloud.com/Sample_Traditional/Entry1.aspx?_ts=637936549120660819

Thanks 

Tousif

Sample_Traditional_Carousel.oml

The issue was, as suspected, related to the theme in use.

It was missing all the needed classes for the carousel to work properly.

Leaving this here in case someone has the same issue.


Thank you

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.