Error sending email:  Invalid credentials for relay
Question

Hi community,

Has anyone ever encountered the problem that emails are not sent or are sent late with the message below? I'm not sure if this question is OutSystems related, but I'm not quite sure what causes this error.


At first, the message seems to indicate that something in our Google G Suite is not set up properly. However, our system administrators indicate that everything is correctly configured and point to OutSystems and the handling of their mail system. This seems to be going through AWS and said to indicate that there might be an e-mail server in AWS not configured properly or something like that. Ultimately, the emails are sent, using the retry mechanism that OutSystems has for this.

My hope is that there is somebody that encountered the same problem before and can point my in the right direction.

Best,

Bart

Solution

Yes. Seems problem at GSuite side only. For check email functionality you can add some free smtp for testing.

regards

Hi,

From above errors it clear that it asking "email which you are using as sender email must be register in GSuite, means it should be a valid email Id with Gsuite account. 

Could you please confirm with your IT team that sender email is a valid email account in G Suite.

regards

Hi Vikas,

I confirmed that the mail account is valid in G Suite. I think this problem is not OutSystems related and is a problem somewhere in our G Suite. I will close this for now.

Solution

Yes. Seems problem at GSuite side only. For check email functionality you can add some free smtp for testing.

regards

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.