Closing a popup screen does not close shadow

Closing a popup screen does not close shadow

I have a popup screen to search for Timesheet numbers.  Sometimes when I close it, and return to the main screen, the shadow remains, and the area under the shadow is inaccessible.  I have attached screenshots to describe the issue.  Refreshing the main screen removes all the data

Before opening screen

Popup Screen

Remaining Shadow (area covered by shadow is inaccesible)

Hi Matt,

Can you confirm that it is possible to interact with controls outside the shadow?

What browser and operating system are you using? Does this happen on other browsers and/or machines?


Hi Marcel

Thanks for your reply

I can interact outside the shadow,

and it happens on both Internet Explorer and firefox.  I haven't tried any other ones.

Hi Miguel,

I have seen the same behaviour during my Developer bootcamp a couple of weeks ago. I'm using Windows 7 and the Chrome browser.


Hey Matt,

Check if your buttons are set to Ajax instead of Submit. Submit buttons that close a popup can cause this.
If you're using Feedback inside the action where you close the popup, check if you're calling the Feedback_Message BEFORE the Popup_Notify and/or Popup_Close action.

One of those two should solve your problem :) (It did for me several times)
I also experienced this problem (
What Antonio said about the submit vs. ajax is correct bu in my case it didn't allways solve the problem. The workaround for me was setting width and height properties on the popup_editor widget.
I had also the same issue a couple of times depending on the flow that I need to refresh the Parent Page.
The workaround that I used to remove the PopUp shadow after the PopUp_Close was to use the action RunJavascript of RichWidgetsExtension and just typed:
"osjs('body div.dropShadow').remove();".

I have the same problem with every browser: Internet Explorer, Firefox, Chrome and Opera.
It also happens with some popups here, at Outsystems Network :P
Thanks.  Setting the size worked for me.
Hi everyone,

Just a quick note that I have notified the support team about this problem so it can be looked at by Maintenance in due time.


Hi all!

I am experience exactly the same problem, and none of the solutions shared in this thread helped.
Any news regarding this issue?


Hi All

This problem has been fixed on the Platform Server, so please update your Platform Server components with or later.
For those of you using the Agile Platform Community Edition, I recommend to download it from or


Miguel Simões João
Thanks for the quick reply!
Will do the update!