How to add section to web.config using Factory Configuration

How to add section to web.config using Factory Configuration

  
Hi,

I have already have set up some customized 'rules' in SCFC (ServiceCenterFactoryConfiguration) to add a module in the web.config everytime the espace is published. Now i have a new challenge, i need to include a complete new section after the system.web section.

Current XSL:

<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

   <xsl:output method="xml" indent="yes" encoding="UTF-8"/>

    <xsl:template match="@*|node()">
        <xsl:copy>
            <xsl:apply-templates select="@*|node()"/>
        </xsl:copy>
    </xsl:template>
    
    <xsl:template match="/configuration/system.web/httpModules">
        <xsl:copy>
            <xsl:apply-templates select="@*|node()"/>
                <add name="ModuleABC" type="ABC.Framework.Security.Authentication.ABC.HttpModule.HttpModule, ABC"  />  
      </xsl:copy>
    </xsl:template>

</xsl:stylesheet>

Which statement(s) to add to create the new section after the system.web section ??

regards,

Paul

 



Guess it would be something like this:

<xsl:template match="/configuration/system.web/">
        <xsl:copy>
            <xsl:apply-templates select="@*|node()"/> 
      </xsl:copy>
    <foo><bar>insert stuff here for example</bar></foo>
   </xsl:template>
It is not as simple like that..... SCFC reports it as being incorrect and refuses to apply it to the web.config....
Hi,

I am new in OSAP. I have wriiten one wcf client(class libray) to consume a webservice and imported it through integration studio successfully. Now my question is how do I integrate the wcf binding configuration file with the web.config file....


Thanks in advance!!!