J2EE integration studio compile error

J2EE integration studio compile error

  
Hello,

I´m trying to compile an extension for J2EE and I get this error:

J2EE Compilation.

'"java.exe"' is not recognized as an internal or external command,
operable program or batch file

I have searched the forum and have configured Integration Studio with the options as was said, with the eclipse, ant.bat and jar as compiler tool options.
Both java and ant seem to have the environment variables configured, since I can run them from the command line.

Any ideas?

Rui Pereira
Hello Rui,

Have you seen this post already?

http://www.outsystems.com/NetworkForums/ViewTopic.aspx?Topic=J2EE-Extension-Compilation-Error


Let me know if it worked for you.

Cheers,

Pedro
Hi Pedro,

Yes I have seen that one, I used it to guide me, but still cant compile it...

Weird thing is that it looks as a envir var issue, but it's configured, and I can run it from anywhere, both java and ant.

Any more ideas?

Rui Pereira
Hello again Rui,

It really seems an environment problem.

Could you please send a snapshot of the screen containing that error?

Do you have JDK 1.6+ installed ?

Below there's a snapshot of what kind of settings you should have in Integration Studio



Cheers,

Pedro
hello again,

I have attached all the info I could think of, take a look, maybe you can shed some light in to this.

C:\Users\rui>set
ANT_HOME=C:\Program Files\apache-ant-1.8.2
JAVA_HOME=C:\Program Files\Java\jdk1.6.0_29

result of path:
C:\Program Files\apache-ant-1.8.2\bin;C:\Program Files\Java\jdk1.6.0_29\bin

regards,

Rui Pereira
solved it, missing a semi-colon on the end of path...

thanks for all the help,

Rui Pereira
Hi Rui,

I'm glad that you found the problem.

Thanks for posting it here, it might help others!


Cheers,

Pedro