Solution gone after upgrade

Solution gone after upgrade

  
Today i tried to upgrade a Outsystems platform server to the latest version (6.0.0.* to latest). After the upgrade i noticed that it was not some kind of upgrade but more a reinstall to the latest version. So i lost my solution, stored in the DB which is still available). When i set the databasename to the old DB in the condiguration tool (outsystems in steat of outsystems_) my solution works again but the service center doesnt work:

There was an error processing your request:

Invalid column name 'OmlHash'.
Invalid column name 'Pending_Version_Id'.

So i'm not able to download/backup the latest version of my solution. What can i do?

For what I understood you upgraded from 6.0.0.X to 6.0.1.X correct? 

Quick side note, all upgrades are reinstalls of the platform binaries, and the database schema is upgraded if it's required.

You didn't lost yoursolution, all data is still stored in the database, unless somehow it got corrupted (the database).

Unless you did install it as a fresh install and started to use another database catalog (I see you mention outsystems and outsystems_ in your message, are they backups one of other or what?) the database should have your data intact

If you by mistake did a fresh install I would advise you to: delete the newly created catalog, rerun the installation of the platform using the correct options to upgrade your current platform, run the configuration tool to upgrade the database schemas (if needed in the checklist)

Best regards,
PC
Pedro,

Thanks for the explanation. I've set the DB to the old one and executed a upgrade. My solution and my service center are working again. But now i got an error on the licensing page:
Invalid object name 'outsystems.DBO.OSSYS_PRODUCT'.
Service Studio is also telling me i cant connect becouse of a licensing problem:
'There was a problem installing the trial license in your 'outsystems' server of the agile platform'
Did you execute the SCInstall.bat ? Was it sucessfully ?

And the System_Components solution?

Best regards,
PC
SCInstal.bat was succesfull but the System_Components.osp wasnt...

Well... SCInstall did not finish but it disappeared before i saw the warning:

C:\Program Files\OutSystems\Platform Server>SCInstall.bat
Service Center Installer v6.0.1.7

Start installing Service Center v6.0.1.7...

Publishing Extension(s)...
Publishing Extension 'OMLProcessor'...
Publishing Extension 'IntegrationStudio'...
Reading ServiceCenter.oml oml file information...
Adding ServiceCenter eSpace to database...
Compiling ServiceCenter eSpace...
Preparing ServiceCenter eSpace deployment...
Deploying ServiceCenter eSpace...
Message 1
  Id         : NoRegisteredServers
  Type       : Error
  Message    : Publishing Error
  Submitable : False
  Details    : There are no registered Front-end Servers. Please contact your Service Center Administrator.
  HelpRef    : 2091
Support@outsystems.com helped me out...:

When you say the default installer, you're referring the Community Edition installation, correct? If you have manually changed the existent database, the upgrade using the Community Edition may create a new database.
 
When this happens, the solution is to use the Platform Server installer available for download in the Agile Network under Downloads, for the 6.0.1.6 version instead, and follow the Platform Server 6.0 .NET Installation Checklist document for the upgrade process. Manipulating directly the OutSystems metamodel can lead to corrupted data and unrecoverable system.
 
Since you've now now manipulated the OutSystems data model manually, we can't guarantee that it will work, so I suggest you rollback the database to a previous backup.

 

Rollback > Platform Server installer and the steps installation Checklist solved my problem...