Extensions: .NET 3.5 issues

Extensions: .NET 3.5 issues

  
Agile Platform supports .NET 3.5

However somewhat type "Var" does not seem to work on the agile platform, it will compile in visual studio, but the agile platform will reject it on publication.

Will outsystems be fixing this issue? .NET framework upgrade?


Until 5.1, Paltform Server only supported .NET 2.0, so while you could use Visual Studio 2008, the projects were set to .NET 2.0 compatibility, so "var" would not work. 
Starting with 6.0, Platform Server supports .NET 3.5.1, so that is no longer a problem.

Best Regards,
Gustavo Guerra
@Gustavo

The extension would compile in visual studio, however it will not be able to publish.

By default is agile platform 6.0 set to run .net 2.0? 
No, it's set to 3.5.1. Do you have .NET 3.5.1 installed at the server?
Gustavo

No, only 2.0 and 4.0

3.5 is not installed, its currently running 2.0 (hence cause of publication issue).

Hi Robert,

Check 2 things:

First in Visual Studio make sure the Target Framework is set to ".net Framework 3.5"

Then in Integration Studio, Edit->Options->.Net->.Net Compiler Tool it should be set to something like "C:\Windows\Microsoft.NET\Framework\v3.5\MSBuild.exe"
If it pointing to the 2.0, version the "Reset Defaults" button should be enough to fix it.


Regards,
João Rosado
@Joao

Integration Studio has already been set to .NET 3.5 however the platform server is running on .NET 2.0

EDIT: After checking .NET 3.5 is installed. but still unable to use .NET 3.5 features. Any ideas?