having trouble with rafael sap explorer

having trouble with rafael sap explorer

  
I just recently downloaded  rafael mysap proxy rar file from outsystems website installed and set it up using the installation instructions.After the setup and configuration anytime i click on visual studio to test the plugin it throws an error exception.
i followed the following instructions:
* Install SAPProxySetup.msi
* Go to "My Documents" folder, "Visual Studio 2005", "Addins"
* Copy the contents to the folder "Addins" to "My Documents" folder, "Visual Studio 2008", "Addins"
* If the "Addins" folder does not exist, create it
* The contents to copy are:
* MySAPExplorer.AddIn
* en-US\MySAPExplorer.resources.dll
* Edit the "MySAPExplorer.AddIn" file you just copied using Notepad
* Change <Version>8.0</Version> to <Version>9.0</Version> (both instances)
* If necessary, correct the path c:\program files\rafaelc\SAPProxyGen\MySAPExplorer.dll
* E.g. in a 64 bits installation, you might need to change to c:\program files (x86)\rafaelc\SAPProxyGen\MySAPExplorer.dll

i have attached a snapshot of the error.Please any tips would be appreciated
i redownloaded the rafael sap proxy again and i still got the thesame error i attached at my first post.Please any help on how to solve this problem will be appreciated.Thanks
Hi folks,

This is an old post, but I'm also having a problem with Rafael Proxy Visual Studio Add-In.
This time when using Visual Studio 2010 and it crashes when I try to Add a New Server.

Any clue of why this is happening?
Pedro Gonçalves wrote:
Hi folks,

This is an old post, but I'm also having a problem with Rafael Proxy Visual Studio Add-In.
This time when using Visual Studio 2010 and it crashes when I try to Add a New Server.

Any clue of why this is happening?
After reinstalling My SAP Explorer, this no longer happened. Probably due to my custom path installation (i decided to install in c:\Program Files (x86)\SAPProxyGen instead of the default c:\Program Files (x86)\rafaelc\SAPProxyGen).

I'm now having another issue, reported here.

Would like to check with one of our issue integrating with SAP via rafael sap explorer. I have successfully connected to the server but unable to generate the code for any of the available BAPI functions. (Screen shot attached)

- Using .NET 3.0
- Visual Studio 10
- Integration Studio 7.0.0.5
Hi Geethan.
 
Sorry for the late answer, but I  was unable to replicate your error.
 
You are saying that you are getting exactly the same error for every BAPI?
 
In fact I don't know the NFD value type refered by the error message.
 
Please tell me the SAP Version you are trying to connect to.
 
Were you able to generate the proxy code for other SAP systems?
Do you think you can use Visual Studio 2008 (or 2005) to see if you get the same error?
Sometime the RafaelC proxygenarator doesn't work well on VS 2010.
 
I'll continue to research a little bit more on this.
Let us know if you get any developments on this.
 
Regards
Miguel
Hi Miguel.

I got the same issue with Geethan. Screen shot attched.
TRD means field "System" in Application Server Data that I add.

Thank you and Best Regards,
Luci