Debugger not working

Debugger not working

  
Hi,

I am having some trouble with the debugger. When I run the application everything seems to be fine, but when I activate the debugger, the request hangs indefinitely and doesn't stop in any breakpoint. When I stop the debugger (while waiting for it to respond), I get the response immediately, just like I do when the debugger is not active. I don't know what might be causing the problem.

Info:
Service Studio 6.0.1.16
Hi Joaquim,

Usually these issues are caused by:
  1. Service Studio not being able to communicate with the server (some firewalls/anti-virus reportedly interfere with the debug session).
  2. Application pool configurations in IIS.
Regarding cause 1, check if you have something in the way that may be causing the issue.

Regarding cause 2, check IIS configurations in the server:
  • Basic Settings... > Managend pipeline mode: set it as Classic.
  • Recycling... > follow the installation checklist instructions below.
In the IIS Management Console, select your machine and then select the OutSystemsApplications application pool. Follow these instructions:
  1. In the Action menu, select the Properties.
  2. Click on the Recycling tab and:
    1. Uncheck the Recycle worker processes (in minutes) option.
    2. In the Memory Recycling group, check the Maximum used memory option and set its value to 60% of the physical server memory or to 800Mb, whatever is lower.
    3. In the Memory Recycling group, check the Maximum virtual memory option and set its value to 1400Mb.
  3. Click on the Performance tab and uncheck the Shutdown worker processes after being idle for (time in minutes) option.
  4. Click the OK button.
Cheers,
Paulo Ramos
Are there different instructions for Windows 2008 R2? Our system administrator reports seeing different recycling options.
Steven Schmidt wrote:
Are there different instructions for Windows 2008 R2? Our system administrator reports seeing different recycling options.
 
 Hi Steven,

Yes, the instructions are available in the installation checklist. For 7.0, you can download it from here:
http://www.outsystems.com/goto/checklist-7-NET

I've included below the relevant part for Windows 2008 R2.


Tuning Internet Information Services
- Configure worker process optimizations


Configure the worker process optimizations:
  1. Expand <servername> and click Application Pools
  2. In the middle pane, click OutSystemsApplications.
  3. In the right pane, under Edit Application Pool, click Recycling...
  4. Uncheck all checkboxes under Fixed Intervals group.
  5. Under Memory Based Maximums, uncheck Virtual memory usage (KB) and configure Private memory usage to be at most 60% of the total physical memory of the machine. Then click Next.
  6. Activate all the Runtime recycling events. These will provide additional information whenever worker process recycle - this information will be logged in Event Log.
  7. In the main window, in the right pane, under Edit Application Pool, click Advanced Settings.
  8. Under Process Model, set Idle Time-out (minutes) to 0 (zero). Exit by clicking OK.
In my case it's probably the firewall that's interfereing (as it is an external server).
What configurations do I have to have in my firewall so the debug works?
Thanks in advance,
Mariana
kill any antivirus-applications you are possibly running. they may interfer even though you don't see it.
Starting on OutSystems Platform 9.0.1.15 and 8.0.1.43, there's a new setting that might help if your debugger is not working properly.
Check out this post.