Disable autofocus in the dropdown search widget
Application Type


How to disable dropdown search widget auto focus?

I have used the dropdown search in the middle of the screen, it will shows the list as well as display the values after saving.

By default , the focus is going to the middle of the screen. I tried with setfocus() and Javascrpt focus 

but I didn't get it.

While using starting selection , I'm getting this issue. Using starting selection option to show the value in the screen.

Thanks in advance


OutSystems UI has a client action SetVirtualSelectConfigs for additional configuration of dropdown search. I haven't tried it, but the options autofocus and focusSelectedOptionOnOpen look promising.



Hi everyone,

Has anyone found a solution for this?

We're having a major headache with this topic, and even if we don't assign a StartingSelection, the SetVirtualSelectConfigs client action renders no effect.

Thank you very much in advance.

Best regards,

Paulo Moreira

*** UPDATE ***

No StartingSelection, using DropdownSetValue client action to set a value on the DropdownSearch Initialized event, and still no luck...

Also, the autofocus property of the ProviderConfigs input parameter, on the SetVirtualSelectConfigs has a default value of Entities.BooleanTypes.Unset ?

Hi @K C S 

May be you need to put this script on ready action to disable auto focus on particular element

const element = document.getElementById('vscomp-ele-wrapper-5970');                                                  // const element =document.getElementById('Id'); where id we can get from inspect tool

element.tabIndex = '-1';



Hi Kiran,

It doesn't work, as Virtual Select resets tabindex="0" each time it sets a value.

Thank you.


We have the same issue. Any progress on a solution?

I have tried all solutions above, is there anything else I can do to prevent this element from being auto-focused when there's a starting selection in it?

This is really troublesome. 

We got an update from OutSystems last week and since then, the issue is gone.

I haven't tested it myself but I see it in the Outsystems UI patch notes that this has been fixed.

Hi, this issue is still happening to me only on MOBILE and I am in a newer version of Outsystems UI (2.18)
Does anyone have a fix?

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.