jQuery Resize not working in Outsystems

jQuery Resize not working in Outsystems

  
Hi anybody aware of this little bug : resize using jQuery not working
Do a simple test:
Create a DIV on a webscreen, give it a class "demo"
Add the following expression to the webscreen
"<SCRIPT>
osjs(function(){
    osjs('.demo')
        .draggable()
        .resizable();
});
</SCRIPT>"
And it will be draggable but not resizable ... (using v7)
Any solutions ??
It works with these version direct from the internet : http://viralpatel.net/blogs/2010/01/jquery-resizable-draggable-resize-drag-tutorial-example.html

So did Outsystems modify not only jQuery base file but also the jQuery UI file ??
Hi Joop,

The resizable itself actually works (and its being used I think in popups), but we don't include any of the css required for the general use of it.
Actually all the jqueryUI features that require css or icons is not included at all.

Thats one of the reasons that OutSystems recommendation is the include your own version of it (I said that to you already once)

Anyway to solve your problem, go to http://jqueryui.com/download
Download it, and include on you page at least the css styles started with "ui-resizable", the "ui-icon" style and the image used by "ui-icon"

We provide jqueryUI javascript as is, apart from some couple fixes. But we don't include 90% of the css or the images.

Regards,
João Rosado
João I will follow your path to include the the content of the JS files in webblokcs to see if that'll work.
I've already tried to incoroporate the files as resources but no luck
Good :)

By the way, remember that with the normal jQuery you need to use $ instead of osjs.
Also what is missing on what we distribute is the css file and images. Don't forget to include those.
"<SCRIPT>
$(function(){
    $('.demo')
        .draggable()
        .resizable();
});
</SCRIPT>"
Regards,
João Rosado
Hi João,

Got it working... this did the trick "...include (on you page) at least the css styles started with "ui-resizable", the "ui-icon" style and the image used by "ui-icon"..."

Thanks for your patience :-)