JBoss Outsystems not listening on port 80

JBoss Outsystems not listening on port 80

  
Dear forum,

I have managed to get Agile Platform 7.0 for Java up and running on CentOS 6.2.
So stack info:
- Oracle XE 11G R2
- JBoss 5.1.0 GA
- AP 7.0.0.5

Apart from getting the current license validated (received license for 6.0 platform which does not run on Linux :-) ),
I already suspect some issues with the current configuration.

The CentOS 6.2 runs inside VMWare workstation. I am able to connect to Service Center via the browser on port 8080:
http://192.168.0.46:8080/ServiceCenter

However on port 80 there is no listening process (netstat -an) , so I cannot connect to ServiceCenter the default way:
http://192.168.0.46/ServiceCenter

Though I manage to login via Service Studio on server 192.168.0.46:8080, this is not what is required..

There should be a JBoss process available on port 80 to connect to!

How can the JBoss listening port be fixed to 80 as required!

Thanks in advance,

Harry
I got following reply from support:
- How to get Outsystems-JBoss back on port 80, where it was installed correctly originally?
JBoss is never set to listen on port 80, when installed with the Agile Platform. JBoss runs with user jboss, which cannot map ports below 1024. So what is done is that JBoss will listen on port 8080 (8443 for HTTPS) and iptables rules are set to redirect traffic from port 80 to port 8080 (and from port 443 to 8443).
The most likely reason for those rules to stop working is if the rules are not mapping the correct IP – that can happen a lot if the IP from your machine is not static.
 
I suggest that you check file /etc/sysconfig/iptables and look for rules that look something like this:
 
-A OUTPUT -d 192.168.3.32-p tcp -m tcp --dport 443 -m comment --comment "outsystems" -j REDIRECT --to-ports 8443
-A OUTPUT -d 192.168.3.32-p tcp -m tcp --dport 80 -m comment --comment "outsystems" -j REDIRECT --to-ports 8080
-A OUTPUT -d 127.0.0.1 -p tcp -m tcp --dport 443 -m comment --comment "outsystems" -j REDIRECT --to-ports 8443
-A OUTPUT -d 127.0.0.1 -p tcp -m tcp --dport 80 -m comment --comment "outsystems" -j REDIRECT --to-ports 8080
 
The rules with the non-127.0.0.1 IP are the ones that may need to be fixed. If the IP listed does not match the one in your machine:
 
[root@VMOS70JAVACENTOS ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:56:9A:4B:6B
          inet addr:192.168.3.32  Bcast:192.168.3.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10934157 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11555288 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3596911561 (3.3 GiB)  TX bytes:3296421677 (3.0 GiB)
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:28168721 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28168721 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4035196482 (3.7 GiB)  TX bytes:4035196482 (3.7 GiB)
 
Then you need to fix it (just edit the file, replace the IP, and issue command service iptables restart).
 
-----
 
- And how to enable asynchronous logging on Linux, because MS Message Queuing will not help me for sure?
The standard installation of Agile Platform for Java will always install message queuing (it is based on JBoss MQueue). If you get that message after uploading a license, we suggest that you:
·         Stop the OutSystems services (service outsystems stop);
·         Run the configuration tool again (/opt/outsystems/platform/configurationtool.sh) and don’t change any setting – just let it run all the way until the end). Do not start OutSystems services if instructed;
·         If instructed, restart JBoss; if not, do it manually by running service jboss-outsystems restart;
·         Start OutSystems services with service outsystems start.
 
This should fix the message and trigger use of asynchronous logging.
Please let us know how it goes.

And in fact that solved the problem!