Re : Error retrieving tables from external SqlServer database

Re : Error retrieving tables from external SqlServer database

I got the following error in the step of retrieving tables from an external database through Integration Studio -->Import --> Import Entities from Database Wizard:

"Error retrieving tables: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding(text/xml; charset=urf-8). If using a customer encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: ....."

The connection configured in service center was tested successful. The wizard shown available databases already and when I selected it and clicked Next button, system tried to retrieve tables and took a long time to do it and finally displayed the above message.  Anyone have solution on it?  Thanks in advance.

Hi Kevin,

That looks like it got a error page from IIS so it was not a valid response.
In the "..." part it should say exactly what happened. Since you say it "took a long time" I would guess it reached the request timeout.

It it was a timeout between the Integration Studio and Service Center you can try to increase the value in IIS and see if it helps.
Then try to find out why it is taking that long (many objects / slow connection / ...)

Note: I assumed a lot of stuff from the information you provided ;)

João Rosado
Hi I have the same error, any one resolved the problem ??
I increase the timeout in IIS and didn't resolve.

Frederico Fernandes
Hello Frederico,

Did you check your database connection?
This error is a timeout and you might have a network/communication problem.

Gonçalo M.
I found the problem, i have a Slow connection with the DataBase, so i make the xif in the virtual machine directly connected with the DataBase.

Thanks anyway
Frederico Fernanes 
Hi guess it was a database connection issue.
Nice to know that you could solve it.

Kind Regards,
Gonçalo M.
Hey there,
Did anyone else got this problem and solved it in another way?

I've increased the parameters in the configuration but still getting "the error".

Pedro Lima.