Internal Error  Invalid compiler output. Object reference not set to an instance of a


while I'm developing and then I publish I got yhis error :

I dont know what's happeneing, but I tried to remove what I added but I always get the same error .

any solutions please ?



Hi @you asen ,

I am not sure but if you are using SQL in your application then this can be issue in SQL side.

I also faced internal issue one time which was due to SQL but I am not sure that issue was same.



The message "object reference not set to an instance of an object" means that you are referring to an object the does not exist or was deleted or cleaned up. It's usually better to avoid a NullReferenceException than to handle it after it occurs 

I am not sure what exactly you doing . Please share the OML file 

Hi @you asen,

Try to refresh all the dependencies of your module and then try again to publish.

If error still persist? Close service studio and then try to publish the module via service center.

Please refer the below screenshot for reference:

Hope this helps.


Manish Jawla


I'm getting the same issue :

Hi Asen,

Have you tried by refreshing all the dependencies as well? 


Manish Jawla

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.