Error plublicar extension

Error plublicar extension

  
Hello,
 
I can not publish extension.

Compilation error
.NET Compilation.

C:\Windows\TEMP\2515c4d5-c066-4d77-9737-4b8e4921a7ef\HtmlConvertToPdf\Source\NET\HtmlConvertToPdf.sln : error MSB4126: The specified solution configuration "Release|MCD" is invalid. Please specify a valid solution configuration using the Configuration and Platform properties (e.g. MSBuild.exe Solution.sln /p:Configuration=Debug /p:Platform="Any CPU") or leave those properties blank to use the default solution configuration.

Please help me, I need to publish HtmlConvertToPDF extension.
Hello Paulo,

That kind of error is commonly related with the Solution Configuration.
The notation Something1|Something2 is for Configuration|Platform. So for default C# projects you will have possible values like Debug|Any CPU or Release|Any CPU.
If you want to build your solution for x86 and x64, your solution must be configured for both platform (actually you just have a AnyCpu config), if not you can explicitly specify the target platform.
In your case this seems like a problem with Visual Studio and its confirguration. What version of Visual Studio are you using?


You can take a look at a previous post, because it's related to this issue:

http://www.outsystems.com/NetworkForums/ViewTopic.aspx?TopicId=7225&Topic=Compilation-Error-Using-Integration-Studio

If you need help after trying this, you can attach the extension and I'll try to see what's the problem.

Best Regards
Gonçalo Martins wrote:
Hello Paulo,

That kind of error is commonly related with the Solution Configuration.
The notation Something1|Something2 is for Configuration|Platform. So for default C# projects you will have possible values like Debug|Any CPU or Release|Any CPU.
If you want to build your solution for x86 and x64, your solution must be configured for both platform (actually you just have a AnyCpu config), if not you can explicitly specify the target platform.
In your case this seems like a problem with Visual Studio and its confirguration. What version of Visual Studio are you using?


You can take a look at a previous post, because it's related to this issue:

http://www.outsystems.com/NetworkForums/ViewTopic.aspx?TopicId=7225&Topic=Compilation-Error-Using-Integration-Studio

If you need help after trying this, you can attach the extension and I'll try to see what's the problem.

Best Regards
 
 Gonçalo,
 
Visual Studio 2008.
Paulo,

I tried to publish the extension using the configurations to work with VS2008 and I had no problems (I used Integration Studio 6.0.1.21).
Please check if your configurations are like this in your Integration Studio (Edit -> Options):
          



Best Regards,
GM
Hi Paulo,

Hope you already got it working.
If you didn't, check my reply on this post: http://www.outsystems.com/NetworkForums/ViewTopic.aspx?TopicId=9113&Topic=integration-with-vb-net-DLL

The problem is that your pc (I guess its a HP or similar brand) has a environment variable that mess up the C# compiler.
You either have to delete the "Platform" environment variable (it's only needed to setup the windows on the first restart ...) or in Integration studio add to the options /property:Platform="Any CPU"


Regards,
João Rosado