Alert: Service Studio and Internet Explorer 10

Alert: Service Studio and Internet Explorer 10

  
Hi all,
 
Internet Explorer 10 is now available as a preview for Windows 7, and some of you have already installed this new version.
However, as stated in the platform’s System Requirements, only IE 7, 8 and 9 are supported.

IE10 currently causes severe issues with Service Studio. You'll get the error "Internet Explorer installation is incomplete":
 
error screenshot
 
We are working on this issue and should have updates to to the platform soon. Version 7.0 already has this issue corrected from 7.0.0.14 and up, even though IE10 is not officially supported yet. As such, we would like to ask you to hold off on installing IE 10 until the appropriate fixes are released, and IE 10 is officially supported.
 
We will update this forum post with the relevant version numbers as they become available.
 
Cheers,
João Atalaia.
Hi João,

Thank you for this important information/ tip..
As a manner of fact I already saw this behaviour and supposed that the cause was what you describe..
At least now I have a confirmation :)

Kind Regards,
Gonçalo M.
Hmmm...
Wasn't there a reply here saying that while not officially supported, the latest versions of Service Studio 7 already fixed this?
I'm using Service Studio 7.0.0.18 and writting this in IE 7 10.0.9200.16438 (the pre-release for Windows 7) and have 0 problems.
Hi Carlos,

as my post above states: 

"Version 7.0 already has this issue corrected from 7.0.0.14 and up, even though IE10 is not officially supported yet"

This was fixed in 5.1.1.35 and 6.0.1.24 as well.

Cheers.
Right.
I'll stop posting when I don't have the appropriate caffeine or chocolate (or both!) levels.
:)
Still, since Microsoft hasn't released IE 10 for Windows 7 yet and only Windows 8 ships with it, it's not much of a problem -- only bleeding edge users will be using it anyway.

Hello,

I wonder if someone who uses version 7.0.0.5 can use Service Studio 7.0 on Windows 8?
 
My client is the final version this is the only chance I've found, is to use a VM with Windows 7 and IE 9.0
 
If anyone knows a way to change this would be very grateful.
 
Thank you.
bruno.mesquita wrote:
Hello,

I wonder if someone who uses version 7.0.0.5 can use Service Studio 7.0 on Windows 8?
 
My client is the final version this is the only chance I've found, is to use a VM with Windows 7 and IE 9.0
 
If anyone knows a way to change this would be very grateful.
 
Thank you.
 Is there any reason why you can't update to Service Studio 7.0.1.10 since it is compatible with Platform Server 7.0.0.5 (or newer)?

From my personal usage, 7.0.1.10 works fine in Windows 8.

If the ServiceCenter of my Client is in version 7.0.0.5, i have no problem in using version 7.0.1.10 to develop?
Thanks!

Hi Bruno,

Yes, Service Studio 7.0.1.x versions are compatible with the 7.0.0.x servers.

Regards,
João Rosado
Any plans to update Service Studio 5.0 to support IE 10?

Some of us are stuck with having to use it...
Hi Carlos,

There are currently no plans to backport it to 5.0 since the version is no longer supported.

Regards,
João Rosado
Carlos Ribeiro da Fonseca wrote:
Any plans to update Service Studio 5.0 to support IE 10?

Some of us are stuck with having to use it...
 
 Hi Carlos,

are you using Service Studio 5.1.1.35 or newer?

The issue describer here should be fixed in those versions. Some other issues regarding with IE 10 and Platform Server have also been fixed in this version, you can look here for some more detail.

Cheers,
Joao Atalaia
Well, this issue happens again with Win 8.1 + IE11 and yes, I'm still forced to work with 5.1.1.36 despite this branch being deprecated. Is there any chance at all to get an unofficial 5.1.1.37 that does cope with IE11?
Hi there,

support for IE11 in Service Studio was introduced in the following versions:

- 6.0.1.30;
- 7.0.1.18;
- 8.0.0.8

Version 5.1 was is no longer supported so we will not be issuing any further corrections for it.

Cheers,
João Atalaia.

Horvath-Szombathy Levente-Laszlo wrote:
Well, this issue happens again with Win 8.1 + IE11 and yes, I'm still forced to work with 5.1.1.36 despite this branch being deprecated. Is there any chance at all to get an unofficial 5.1.1.37 that does cope with IE11?
Well, if you're using Windows 8.1 on a recent PC, one with a secong generation Core i5 at least, you can set up a VM with, say, Windows XP SP3 on Hyper-V. It's what I did, because, yeah, sometimes we're stuck using old unsupported stuff -- not just OutSystems. Another bonus is that, since I use VMs for development, I don't mess up the host OS and it still runs BF3 fine even without having to stop the Hyper-V services.
 
Or you could use VirtualBox, it has better video performance than Hyper-V but it doesn't support dynamic memory.
Bit of a thread necro-ing here.

I'm having this problem using Service Studio 5.1.1.36 and IE 11 in windows 7 32 bit. Any way to make this work?
The only solution I've found was to do development on a virtual machine that runs an OS with IE10. Sorry for the bad news.