Java 1.7 and Integration Studio 

Java 1.7 and Integration Studio 

Hello all,

If you try to publish a extension through Integration Studio into a OutSystems Platform for Java, and have Java 1.7 installed you may run into problems.
Specifically, the following error may appear: Incompatible Java Version: "Extension was compiled in OutSystems Integration Studio with a Java version not compatible with the Java version on the OutSystems Platform.".
This is because the extension files are compiled on the client machine and since Java 1.7 is installed its usually the one that is used to compile them.
To overcome this problem we recommend that you uninstall any Java 1.7 on a machine used to develop extensions for the Java version of the OutSystems Platform, and install JDK 1.6 instead.

Best Regards and happy extension coding,
Rui Eugénio
Is there any other way around this instead of uninstalling Java 1.7 ?

I have the following settings in my machine:

  JAVA_HOME=C:\Program Files (x86)\Java\jdk1.6.0

You don't need to install JDK 1.6, if you follow these steps.

1. Select you project, then the menu Project -> Properties

2. Enable project specific settings, and select the compiler compliance level to 1.6.

Remember to perform these steps for every eclipse project that you work on! Happy programming!