Tip: Community Edition keeps uploading an expired license

Tip: Community Edition keeps uploading an expired license

  
Edited on Feb 15 2013 - corrected procedure for applying fix
Edited on Mar 1 2013 - problem fixed in new Community 7.0.1.7


Symptom

You are running Agile Platform Community Edition 7.0.
After the initial 30-day trial license expires you upload the Community license, but after some time the expired license is uploaded again.
This problem happens repeatedly - whatever you do the expired license keeps popping up.


Cause

Due to a bug in the Community Edition the server does not realize the trial license has expired and continues to upload it.


Resolution

New This problem is permanently fixed in the new 7.0.1.7 Community Edition. Simply obtain it from www.outsystems.com/download/full.

Alternatively, the attached tool will permantely fix this problem by preventing the Community Edition to upload a trial license after it expired.

To apply this tool use the following instructions:

  1. Close all running Service Studios that may be connected to your Platform Server;
     
  2. Upload your community license file in Service Center;
     
  3. Place the attached FixCommunityTrialLicense.exe into the Agile Platform installation folder (e.g., C:\Program Files\OutSystems\Platform Server);
     
  4. Run FixCommunityTrialLicense.exe located in the folder.
    If in Windows Vista/7 run the tool by right-clicking and choosing Run As Administrator;
     

Final notes

After you apply this procedure do not upload a community license again. If you do, you may need to repeat this procedure.
If you have any problems using this tool please let me know by replying here.

Cheers,
Acácio

 
Hi,

I tried this fix, however it didn't work. What else to try/check?
Regards,
Mart
Also, not work with me. It askes me again for licensing after machine restarted
Hello,

If the fix is not working for you, try following the steps outlined in the first post in the following order:

1. Place the file into the Agile Platform installation folder.
2. Upload your community license file in Service Center.
3. Run FixCommunityTrialLicense.exe located in the folder. You will need to run it by choosing Run as Administrator in Windows Vista/7/8.

If you still run into problems using this procedure, please let us know.

Best regards,
Ricardo Silva
Hi Ricardo,

This solved the issue !

Regards,
Mart Meier
For those of you who had this problem, this is now fixed in the Agile Platform Community Edition. Simply obtain the newest patch at www.outsystems.com/download/full 

Thank you for your patience.

Cheers,
Acácio Porta Nova