[Salesforce Connector] Need help with salesforce connector installation

[Salesforce Connector] Need help with salesforce connector installation

Forge Component
Published on 19 Oct (2 days ago) by OutSystems
9 votes
Published on 19 Oct (2 days ago) by OutSystems

I am running an eval version of the platform ( and I am trying to test the SF connectivity without success.  After downloading the connector OSP I opened it and did a 1-click publish to my local system.  This gave me a few warnings (e.g. "Missing Dependency. Could not find the 'SForce' Extension in this server. Application runtime errors might occur.") and 1 error about intellectual property rights, but the last entry in the log suggested the publish was done successfully.

When I tried to reference the connector in my eSpace, I get a message saying the SForce eSpace is using missing references and I should open the eSpace and refresh the references. Ok, so I do that and once the references window closes, I end up with 158 errors and 196 warnings in the eSpace.

I've already tried deleting and reinstalling the connector several times with different combinations of action, but I can't seem to get anywhere.

Am I missing something during the installation, or is this because I am using an eval version?
Also, how do I resolve the IPP error?


Although the publish might be successfull, it doesn't mean all extensions/espaces are published correctly!

the ipp-issue you can fix by uploading the downloaded osp to http://www.outsystems.com/ipp and follow the instructions.
I suggest do that first and try to publish your newly received osp and start from there.

Good luck!

After going through the IPP process, I received a new OSP file, deleted the installed connector application and re-installed from the new file.  This time everything work without errors.  Eliminating the IPP issue did the trick.  This information may be something worth noting on the connector download instructions.


I then proceeded to try and reproduce the functionality in the demo video.  

In order to get the connector to work I finally figured out that the SF login credentials needed to be stored in 2 site properties "Salesforce_Username" and "Salesforce_Password". The actual credential values can be stored in the "Default Value" atrribute.

NOTE:  The one piece of information that is difficult to figure out is that SF requires a third security token as part of the login credentials during an API call.  I found the following instruction on the SF site:

How to enter your security token:

When accessing salesforce.com either via a desktop client or the API from outside of your company's trusted networks:

If your password = "mypassword"
And your security token = "XXXXXXXXXX"
You must enter "mypasswordXXXXXXXXXX" in place of your password

I combined my password & token in the "Salesforce_Password" site property and everything magically started to work.

Hope this helps someone in the future.


We're truly sorry about this occurrence. IPP has been removed from the latest version of Saleforce component.

Thanks for posting your suggestions and workarounds for the rest of the community.

I have been testing the connector against a SF developer environment with the standard test data and everything was working fine.

When I changed the login credentials to integrate with our actual SF environment, I started running into problems.  With a little debugging I found out that we have customized some of our SF objects and that seems to be the problem.

Apparently the connector needs to be modified to include "__c" behind the entity names when making API calls to SF.  How would I go about to do the modifications?



I found this thread elsewhere on the forms which describes how to access custom objects using the salesforce connector: http://www.outsystems.com/forums/discussion/7077/integrate-with-salesforce/#Post20058.