Agile Platform in Windows server 2012

Agile Platform in Windows server 2012

  
Hi, 
Can someone tell if the Agile Platform Installer version 5.1.0.22 (Community Edition) can be installed in Windows server 2012?

Thanks
Mario -

5.1 is no longer supported. Since Windows 2012 support is forthcoming, if 5.1 works in 2012 it is by luck, not by design. Upgrade to 6 (or better yet, 7!) now and wait for 2012 support coming soon, that's my suggestion.

J.Ja
@Justin James - will Agile Platform 7 work on Windows Severs 2012? If not, any idea when this is coming?

Thanks.
Marco -

The system requirements for 8 (http://www.outsystems.com/goto/System-Requirements-8) do not mention Server 2012, which is a bit surprising to me. I'd ask the folks at support.

Honestly... now that I've used Server 2012 a bit, I hate it so much that I don't care if it ever gets supported. I know that's not what a business IT department cares about, but honestly... 2012 brought some great technical updates but is so miserable to use (good luck trying to figure out just how to reboot a server without going to command line!) that I have no desire to upgrade to it anyways... :(

J.Ja
Hi Marco,

We expect to support Windows Server 2012 by the end of this semester/ the following. However, only for OutSystems Platform 8+.
As soon as we have a planned date for release, we will let everyone know.

Edit: Update to the planned release date.

Edit 2 (October 6th, 2014): Support for Windows Server 2012 will only be available for OutSystems Platform 9+, and the version of Windows Server 2012 we will support is the "R2".
I've used APv7 in win 2012 without a problem so far, but this is NOT supported by OutSystems

You can use it at your own risk...

Best regards,
PC
Hey Justin,

FYI: I found using ALT-F4 from the desktop was the quickest way I could find to do that via RDP! Otherwise you need to use that stupid pop out panel on the RHS of the screen then under "COG" settings... but from RDP that method proves to be... let's say... challenging!
Justin James wrote:
Marco -

The system requirements for 8 (http://www.outsystems.com/goto/System-Requirements-8) do not mention Server 2012, which is a bit surprising to me. I'd ask the folks at support.

Honestly... now that I've used Server 2012 a bit, I hate it so much that I don't care if it ever gets supported. I know that's not what a business IT department cares about, but honestly... 2012 brought some great technical updates but is so miserable to use (good luck trying to figure out just how to reboot a server without going to command line!) that I have no desire to upgrade to it anyways... :(

J.Ja
Windows Server 2012 is great. In my opinion better than the previous editions.
To reboot the Server 2012 you just need to do the same has in Windows 8: WIN + I and then click in the power button.

We have been using Outsystems 8 including CE with Server 2012 without any problem.
 
Hi Arlindo,

Are there any news regarding support on Windows Server 2012?
I'd like to move a Development Environment into a Windows Server 2012 machine, but need to be sure it is supported.

Arlindo Lima wrote:
Hi Marco,

We expect to support Windows Server 2012 by the end of this semester/ the following. However, only for OutSystems Platform 8+.
As soon as we have a planned date for release, we will let everyone know.
 
 
Hi Nuno,

Support for Windows Server 2012 has been delayed. We still don't have a planned release date, but we're committed to support it before the end of Windows Server 2008's mainstream support (January, 13th, 2015).
We're targeting Q4, 2014 for Windows Server 2012 support.

Fortunately, upgrading the Operating System (OS) will be easy, as one of the capabilities of the Platform is exactly the portability between stack versions. When upgrading, you'll just need to install the Platform on top of the new OS, and OutSystems will take care of generating code that runs on top of the new OS from the models you had previously created.
It is unfortunate that official support for Windows Server 2012 has been delayed for so long, although we appreciate OutSystems not wanting to give the goahead without having done their proper validation.

Does anyone know if V8/.Net will work (unofficially) on 2012 ?  If so, are there any special configuration steps to take ?  

It is becoming increasing difficult to get new systems with Windows Server 2008, so any success stories on 2012 would make my weekend!
Hi Adam,

Indeed, there is a lot of work involved in certifying the OutSystems Platform to run on top of a new operating system:
  • We have to conduct extensive testing to make sure everything keeps working as expected;
  • Solve the issues introduced by breaking changes of the new version of the operating system (and we always hit some);
  • Analyze how can we take advantage of the new features and performance improvements of the new operating system;
  • Make sure we provide an upgrade path with minimal downtime on our customers’ Production environments;
  • ...
Before doing all these validations, we can’t recommend or support using the Platform on top of Windows Server 2012, especially in your Production environment. Please avoid it.

However, and after this disclaimer, I can tell you that many of the issues we find when supporting a new operating systems are small. Besides, they might not affect the way you use the Platform (e.g. if in Windows Server 2012 there is a problem with the multilingual feature, but you are not using it in your applications, you won’t have any trouble).
Carlos Henriques is using version 8 on top of Windows Server 2012… Let’s see if someone else will share their experience.

Alternatively, if you can influence the installation of the operating systems your OutSystems environments use, Windows Server 2012 includes downgrade rights to any earlier version, including Windows Server 2008 (R2). All Windows Server 2012 license types allow this: Volume Licensing, OEM and Retail (Full Packaged Product). This would be your best option.

Regards.
Hi Arlindo,

Do you have any updates on OutSystems Platform compatibility with Windows Server 2012 ?

Thanks,
Hi Adam,

You will be able to run the Platform on top of Windows Server 2012 by the end of Q3/ beginning of Q4.

Regards.
Hi Arlindo,

Will that also include 2012 R2 Server also?

Regards, Mark
Yes, both Windows Server 2012 and Windows Server 2012 R2.

Edit (October 6th, 2014): Support for Windows Server 2012 will only be available for OutSystems Platform 9+, and the version of Windows Server 2012 we will support is the "R2".
Great, thanks Arlindo.  One more question.  I assume that version 9 will be compatible with Windows Server 2012/2012 R2.  Do you know if there are any plans to make version 8.0.1 compatible as well ?

Regards,
Adam
Yes, the support for Windows Server 2012 will also be extended to version 8.0.1.

Edit (October 6th, 2014): Support for Windows Server 2012 will only be available for OutSystems Platform 9+, and the version of Windows Server 2012 we will support is the "R2".
As the Version 9 System Requirements docment does not list Windows Server 2012 as a supported OS and it is the beginning of Q4, can you please provide an update on when Windows Server 2012 / 2012 R2 will be supported.

Some of my more tech-savvy customers are becoming uncomfortable with remaining on 2008.  

Thanks,
Hi Adam,

Windows Server 2012 isn’t listed in the “OutSystems Platform 9 - System Requirements” document because the current Platform Server revision (9.0.0.2) doesn’t support it.
We are releasing support for Windows Server 2012 in the end of October. When we release the revision patch with this support, we will update the System Requirements document as well.

I’ll also add that support for Windows Server 2012 will only be available for OutSystems Platform 9+, and the version of Windows Server 2012 we will support is the "R2".


Regards.
WIndows Server 2012 R2 is now officially supported (starting with revision 9.0.0.6).
9.0.0.6 is already available in the Downloads section.
Great news Arlindo.  Thanks for letting us know !
Arlindo Lima wrote:
WIndows Server 2012 R2 is now officially supported (starting with revision 9.0.0.6).
9.0.0.6 is already available in the Downloads section.
thanks! :)