What I like to see:
to be able to set the labels of the conditions instead of seeing 1,2,3,4 and otherwise
do/while/do or for-loop
I really would like to see a simple do/while on a condition, instead of a cumbersome if statement. the "cycle" note is a nifty feature with it.
wether is should be a for-loop with just an integer or a do/while I don't mind.
except for esthetics perhaps, because I don't like "breaking" out of a for-loop