Allow us to rename the switch conditions
Service Studio
OutSystems 10

It would make the actions that use this widget, more readable.

Indeed, that's one of the reasons I almost never use the switch, since it's visually nog possible to see what's what.
I have some mixed feelings about this one.

Understand why it should be possible (think it's strange that it still not possible to do comparing with the other widgets) but I've used the swich several times and till now still don't mind that I can't set the swich name.

When I've used the swich I more want to see the conditions so I must click on it anyway.

So mixed feelings :)

@Evert: well, that's exactly what is requested, be able to name the conditions. A switch is just a collection of IF-statements, so just as with the IF, one should be able to name the conditions.
Ah-ha read it to quickly :)

You got my vote!
2013-07-11 10-16-10
David Salvador


I'm happy to announce that your idea is already available on the last release of the OutSystems platform 10.

Thank you for your time and collaboration in making OutSystems platform better.