[In-App Chat Web] There was an error processing your request. Please try again later ...

[In-App Chat Web] There was an error processing your request. Please try again later ...

  
Forge Component
(2)
Published on 2017-11-23 by Labs
2 votes
Published on 2017-11-23 by Labs

Hello all,

I am working on getting the In-App Chat Web, which can be found in the Forge. After setting FireBase and going through the manual several times, I still can not get the chat working. When running the application I get to see a blank screen with:

There was an error processing your request. Please try again later ...

When I look in the Service Center, I see the following error:

Error executing child request for HomePage.aspx.

Environment Information             eSpaceVer: 7 (Id=350, PubId=412, CompiledWith=10.0.702.0)

RequestUrl: https://darioush.outsystemscloud.com/InAppChatWebSample/Home.aspx?_ts=636555808650213118 (Method: GET)

AppDomain: /LM/W3SVC/79/ROOT/InAppChatWebSample-53-131644538569467307

FilePath: C:\OutSystems\Sandboxes\YJY5LF076\Platform Server\running\InAppChatWebSample\

ClientIp: 213.125.8.138

Locale: en-US

DateFormat: yyyy-MM-dd

PID: 66924 ('w3wp', Started='1/1/2018 10:43:01 AM', Priv=653Mb, Virt=18312Mb)

TID: 81

Thread Name:

.NET: 4.0.30319.42000

Stack:

[1] Exception of type 'System.Web.HttpUnhandledException' was thrown.

   at System.Web.UI.Page.HandleError(Exception e)

   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

   at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

   at System.Web.UI.Page.ProcessRequest()

   at System.Web.UI.Page.ProcessRequest(HttpContext context)

   at System.Web.HttpServerUtility.ExecuteInternal(IHttpHandler handler, TextWriter writer, Boolean preserveForm, Boolean setPreviousPage, VirtualPath path, VirtualPath filePath, String physPath, Exception error, String queryStringOverride)

[2] 'Post' Web Block is incompatible with the 'WebPatterns' module definition. Please update it.

   at proxy_InAppChatWeb_WebPatterns.Flows.FlowContent.WBlkPost.get_wtIcon()

   at ssInAppChatWeb.Flows.FlowInAppChatFlow.WBlkInAppChat.FindControl(String id)

   at ssInAppChatWeb.Flows.FlowInAppChatFlow.WBlkInAppChat.InitializeComponent()

   at ssInAppChatWeb.Flows.FlowInAppChatFlow.WBlkInAppChat.OnInit(EventArgs e)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Control.AddedControl(Control control, Int32 index)

   at System.Web.UI.Control.AddParsedSubObject(Object obj)

   at proxy_InAppChatWebSample_WebPatterns.Flows.FlowContent.WBlkModal.OnInit(EventArgs e)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Control.AddedControl(Control control, Int32 index)

   at System.Web.UI.Control.AddParsedSubObject(Object obj)

   at proxy_InAppChatWebSample_LiverpoolTheme.Flows.FlowLiverpoolBase.WBlkLayout_Liverpool.OnInit(EventArgs e)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Control.InitRecursive(Control namingContainer)

   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

What kind of actions do I have to take to get it working?

Solution

Hello Darioush,

Looking at the error it seems that you may have some broken references between In-App Chat and Silk UI (WebPatterns module).

Please try to refresh references in both eSpace modules ("InAppChatWeb" and "InAppChatWebSample") and let us know if that solved the issue.

Cheers,

Samuel Jesus

Solution

Samuel Jesus wrote:

Hello Darioush,

Looking at the error it seems that you may have some broken references between In-App Chat and Silk UI (WebPatterns module).

Please try to refresh references in both eSpace modules ("InAppChatWeb" and "InAppChatWebSample") and let us know if that solved the issue.

Cheers,

Samuel Jesus


Hi Samuel,

Great! it seems to work for now. I think the problem was the outdated WebPatterns module, Now it's time to find out how I can generate automatic answers.

Thank you Samuel.