[Dublin Template] P10: Incompatible dependencies to RichWidgets\Popup_Upload

Forge Component
(48)
Published on 9 Mar (4 weeks ago) by OutSystems R&D
48 votes
Published on 9 Mar (4 weeks ago) by OutSystems R&D

Hi!

Just to inform that on our P10 infrastructure, after a maintenance update of the platform to version Version 10.0.1019.0 for security reasons, there are incompatible dependencies in "Dublin Template" application 3.1.18, module "Template_Dublin", which depends on "Silk UI Web" 3.3.3, to RichWidgets\Popup_Upload (new optional input parameter "Token").

Incompatible DependencyModule 'Template_Dublin' uses web screen 'Popup_Upload' that is incompatible with its definition in module 'RichWidgets'. Runtime errors may occur. Consider refreshing dependencies from 'Template_Dublin' to 'RichWidgets'.


The problem is just with module "Template_Dublin", the template, which for now is not an impediment, but it would be nice that a new version of "Dublin Template" could be release with this fixed, as it is a system module which cannot be manually updated.

I believe all other template applications will have this same problem.

--Tiago Bernardo

Same Issue on our P10 (10.0.1021) platform and can confirm that the issue is with at least Dublin, Lisbon, Liverpool, and Website Templates.

Still no solution for these issues??


Thanks

-- Alberto Manzanilla

Yes. After the OutSystems patching, RichWidgets has some missing references and Template_Dublin being a system module, not able to make any changes to it. Though it may not have immediate impact, it would be nice to have a fixed updated version for the same.

Solution

Hi all,

Due to a change in RichWidgets in Platform Server 10.0.1021.0 some references to Popup_Upload might become broken and a refresh references is needed. 

However, publishing the running version of the "All" solution should have fix it automatically. Can you confirm you did this step?

In any case, we will upload new versions of the templates in Forge with the problem fixed soon.

Thanks for reporting and sorry for any inconvenience it might have caused.


Regards,

-- Miguel Rebelo


Solution

Good tip Miguel!

Using Solutions and publishing the Current Running Version is actually the way we, IT-users of the platform, have to refresh dependencies of system modules, like the Dublin Theme. This worked perfectly!

For the others in this thread, if you want just to try it to have it solved without republishing the complete factory with the "All" Solution, just create a Solution named, for example, "TemplateDublin", add as components the module "Template_Dublin" and then publish the Current Running Version. This will solve the issue for the Dublin template.

---

--Tiago Bernardo

Miguel Rebelo wrote:

Hi all,

Due to a change in RichWidgets in Platform Server 10.0.1021.0 some references to Popup_Upload might become broken and a refresh references is needed. 

However, publishing the running version of the "All" solution should have fix it automatically. Can you confirm you did this step?

In any case, we will upload new versions of the templates in Forge with the problem fixed soon.

Thanks for reporting and sorry for any inconvenience it might have caused.


Regards,

-- Miguel Rebelo




Hi everyone


The new version of Silk UI and Templates are now available in Forge. 


Regards, 

José Rosário