Technical Preview: SEO-Friendly URLs for Reactive Web Apps

Hi!

With the release of Platform Server - 11.12.0, you’ll now be able to activate the Technical Preview feature SEO-Friendly URLs for Reactive Web Apps.

This Technical Preview feature needs to be enabled in LifeTime.

 


With this release you will be able to customize your Reactive Web app's URLs for better search engine results:


Create rules in Service Center to simplify your URLs

 

Use Redirect rules in Service Center to  redirect browser requests from the old domain or subdomain to the new URLs

 

Customize how the URL of one screen shows in the browser directly in Service Studio

 


You can learn all about this feature by checking out the Technical Preview - SEO in Reactive Web Apps documentation page


We encourage you to try it out and give us your feedback!

mvp_badge
MVP

Awesome!

Thanks Vitor for sharing this information. I was waiting for this feature since long, will try this for sure.

Champion

Thank you very much Vitor. Glad to see this feature enabled in Reactive Web Apps. A lot of B2C webs actually require this and we were looking for the same to have :) 


I will look into the feature and share feedback for sure. 

Wow, Much needed features for B2C apps. I will check this.

Thanks Vitor and OutSystems Team.

Thank you Vitor for sharing this!

Thanks @Vitor Teixeira for sharing this update with us.

Champion

Been waiting for this.

Thanks

Great! We'll try it out and share feedback.

mvp_badge
MVP

It sure will help a lot, great.

mvp_badge
MVP

Awesome!!!

Very nice, great improvement by having this configuration directly in Service Studio development time.

Great Update, thanks for sharing!!

Champion

Most awaited update on Reactive apps. Thank you.

Great News, Thanks for sharing !!!

mvp_badge
MVP

So many people think it is great, looking at the amount of replies above, which I agree with.

But who from the above people already tried it out and likes to share their experience with it?

Unfortunately, so true Daniël... I have subscribed to this topic to get useful information of news, people sharing experience, or questions, but all I get is notifications of "great", "thanks for sharing", "awesome"...
Probably at this time most are not even using platform 11.12.0 which is a requirement.

We have 11.12.0 in one of our infrastructures but we have not yet had time to test it, as most of our developments there are still in Traditional Web and for internal applications for which we don't make use of SEO.

--Tiago Bernardo

I am having an issue with this technical preview feature. I have configured such that anyone entering just our domain name (e.g. https://server) is redirected to a Reactive App. I get this error. If I click RELOAD then the reactive web app loads as expected.

Console

ErrorScreen.js:55 Cannot read property 'props' of null

TypeError: Cannot read property 'props' of null

    at Object.s.cloneElement (https://server/scripts/OutSystemsReactView.js?ycH4VlTgX1BuQivzCNiy4Q:3:18403)

    at t.render (https://server/scripts/OutSystemsReactView.js?ycH4VlTgX1BuQivzCNiy4Q:7:23149)

    at c._renderValidatedComponentWithoutOwnerOrContext (https://server/scripts/OutSystemsReactView.js?ycH4VlTgX1BuQivzCNiy4Q:2:21192)

    at c._renderValidatedComponent (https://server/scripts/OutSystemsReactView.js?ycH4VlTgX1BuQivzCNiy4Q:2:21271)

    at c.performInitialMount (https://server/scripts/OutSystemsReactView.js?ycH4VlTgX1BuQivzCNiy4Q:2:17272)

    at c.mountComponent (https://server/scripts/OutSystemsReactView.js?ycH4VlTgX1BuQivzCNiy4Q:2:16324)

    at Object.mountComponent (https://server/scripts/OutSystemsReactView.js?ycH4VlTgX1BuQivzCNiy4Q:4:7872)

    at c.performInitialMount (https://server/scripts/OutSystemsReactView.js?ycH4VlTgX1BuQivzCNiy4Q:2:17398)

    at c.mountComponent (https://server/scripts/OutSystemsReactView.js?ycH4VlTgX1BuQivzCNiy4Q:2:16324)

    at Object.mountComponent (https://server/scripts/OutSystemsReactView.js?ycH4VlTgX1BuQivzCNiy4Q:4:7872)

s @ ErrorScreen.js:55

Logger.js:477 ErrorScreen [2021-06-10T00:54:16.631Z]: [ErrorScreen] Cannot read property 'props' of null 

U @ Logger.js:477

moduleservices/moduleversioninfo?1623286456424:1 Failed to load resource: net::ERR_CERT_COMMON_NAME_INVALID

OutSystemsManifestLoader.js?Uno7DkMuu4+3RKfSExTIUg:63 Uncaught (in promise) Error: Unable to access '///moduleservices/moduleversioninfo?1623286456424'. Error Code: 0


    at XMLHttpRequest.xhr.onerror.xhr.ontimeout (OutSystemsManifestLoader.js?Uno7DkMuu4+3RKfSExTIUg:63)



mvp_badge
MVP

Hi Stephen,

If you have a question or problem please post this as a new question. Only then you will be able to mark a reply for another community member that answers your question or solved your problem as a solution.

Regards,

Daniel

Hi @Stephen Geyer,

We would appreciate it if you could follow @Daniël Kuhlmann suggestion of creating a new post for your question, so other users might benefit from the solution in a more efficient way.

Meanwhile, if you used "https" in the base URL of your rule, that might be causing the problem. If so, please try applying the same rule but without any protocol.

Please let us know if this fixes the issue you are experiencing.

Cheers,
Vítor Teixeira

After analyzing this issue in more detail, we concluded that it occurs because the React version was not updated to the latest version available for Reactive Web runtime (React 16) in that environment. It shouldn't be a frequent problem, but there were some exceptions.

Hope you can now continue to use this functionality and provide feedback.

Thanks!

V´ítor Teixeira

Hi team,

I'm using the new site rules with custom subdomains. Examples:
- Site1 -> site1.mydomain.com
- Site2 -> site2.mydomain.com

It's working fine.
I'm facing a particular issue. When user logs in to Site1, and then navigates to Site2, then the session seems to be lost, because it's going to Login page of Site2 (and the user is already Registered through previous Site1).

Hope someone could provide some guidance.

Regards!

Hi Hector, apologies for the late reply. 

If this problem persists, please open a support case as this problem might not be related exclusively to this technical preview feature. It might be related to Cookies configuration on the domain, for instance.

Best regards,
Vítor Teixeira

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.