[DB2 iSeries Connector] DB2 Connector connection string   

[DB2 iSeries Connector] DB2 Connector connection string   

Forge Component
Published on 2013-02-21 by Rúben Gonçalves
12 votes
Published on 2013-02-21 by Rúben Gonçalves

I am using db2Connector extension to connect to a db2 database. In a SELECT query i have no problem, but when using INSERT i get a  SQL7008 error. I googled and seems the connection commit mode should be set to Commit immediate (*NONE ), or AutoCommit set to Yes. My problem is that i don't know what connection string property should be used. i tryed several ("AutoCommit", "CommitMode", etc..) and i always get the error "The ConnectionString property is invalid." IBM documentation refer to oledb and odbc connections strings, wich is not the case. Any idea of what is the right property, or where can i find documentation about it?

Thank you
best regards

António Barroso
Hi everyone,

I'm also having this same error (The ConnectionString property is invalid.) with SELECT statements in the DB2Query action. I've validated this connection string (here and here) and all seems fine, though.

Where can I find further info about this exception?
Can anybody recommend any further troubleshooting methods?


Pedro, did you solved it?

I'm having the same problem and I don't see any reply to your question...
Hi Pedros and António,

Have you seen the connection string example, that goes with the sample?
If not this was what I was using:
dotnet: "Server=localhost;Port=3306;Database=test;Uid=root;Pwd=xxxpassxxx;"
java: "jdbc:mysql://localhost:3306/test|root|xxxpassxxx"

Hope this helps you out.



just to give you some help: 

has a lot about this commitment.

Just to give you some background.
On an i-series there are the traditional file (PF-DTA) they hold data en LF (logical files) which are basically indexes. As the I-series started of with their own proprieraty database, this did not run under commitment control. 
When using the interactive SQL tool on the I-series (from the commandline : STRSQL) you can query all PF-DTA files  and LF files .
BUT when using a jdbc connection it is required that all the files run under commitment control.
When creating a schema from the STRSQL command, all commitment control is automatic started. And you should be able to connect and retrieve all the data. 
Create schema info on I-series


Thanks for al the replyes guys!

Thank you. I didn´t resolved the issue so i used a diffente driver to access db2
I believe that in order to use commitment control you need to be journaling the files.