.NET Compiler Error in 8.0.1.8

.NET Compiler Error in 8.0.1.8

  
I'm trying to publish the csv extension I got from the forge and I'm getting the following error:

.NET Compilation.
 
C:\Users\cory\Downloads\Csv-1.0.3\Source\NET\Csv.sln.cache(59,5): error MSB4126: The specified solution configuration "Release|MCD" is invalid. Please specify a valid solution configuration using the Configuration and Platform properties (e.g. MSBuild.exe Solution.sln /p:Configuration=Debug /p:Platform="Any CPU") or leave those properties blank to use the default solution configuration.

No warnings before just the error.

I was able to publish this into a different personal environment just fine in v 8.0.1.7, but it was on a different computer.

Any ideas?

Cory
Hi Sampson,

I noticed the issue persists (http://www.outsystems.com/forums/discussion/11711/foreign-module-error-when-publishing-in-personal-environment/) so I'll get in touch via email to make sure we get to the bottom of this. :)

Cheers!
Davide
Hi Sampson,

This is the same problem as in http://www.outsystems.com/forums/discussion/9113/integration-with-vb-net-dll/
It is related with the way your pc is configured and it messes up the default values of the .Net compilations. (usually its a configuration HP pcs)

Copying the reply to here just to make it easyer:

The problem there is because on your pc you have a environment variable in your computer PLATFORM set to "MCD". And the .net compiler assumes that value as the default.
http://social.msdn.microsoft.com/Forums/en-US/msbuild/thread/3c4e9c3f-2bf2-436e-80de-e000a7dda8bd/
It doesn't look anything related with the vb project.

So, either:
  • remove that environment variable
  • or go inside Integration Studio, Edit -> Options -> .NET and in the end of the compiler tool options add: /property:Platform="Any CPU"
Note: that was assuming the project had a "Any CPU" target

Regards,
João Rosado