iOS (and Andriod Chrome) and RichWidgets\Input_Calendar Problem

iOS (and Andriod Chrome) and RichWidgets\Input_Calendar Problem

  
I discovered a problem with RichWidgets\Input_Calendar on my iphone 5 and an ipad3 (iOS7, Safari or Chrome browser) and on Android using Chrome (the default Android browser seems to work fine).  When editing a record, the dates come up blank even though data is there in the database.  I found this in our licensed environment, but replicated it in my personal environment (very simple espace attached).

see
https://cory.outsystemscloud.com/Dates/Home.aspx

Any ideas?  We are using 8.0.1.7 in licensed environment and in personal environment.
Cory
Cory -

We have seen this too.

We cloned RichWidgets and customized it to correct this. There is a line in the JavaScript (forget what it is exactly, do a search for "native" I think and you will find it) which controls if the native date picker is used or the OutSystems one. We had to mess with this a bit to get the right settings for the iPhones to handle dates right.

J.Ja
Thanks for the heads up Justin - unfortunately, I'm not a JavaScript guy.  I'm looking at it, but struggling to make sense of it.  One of the major reasons we went with OutSystems was because it would allow us to develop without having to know how to get into the bits.

It seems to me that OutSystems should fix this since this is a component they deliver with their platform.

Cory
Cory -

Get with the support team, they can take care of this for you. We only did it ourselves because we already had experience with this in the first place.

J.Ja
Thank you James, for providing the fix!
FYI - support is looking into this.  It isn't a problem on an espace I created in a brand new personal environment (8.0.1.8 platform version and Service Studio Version), but it is in my personal and licensed environments that were originally set up in 8.0.1.5 and 8.0.1.7 respectively.

Cory