Spaces don't publish

Spaces don't publish

  
Hi everybody,
After we update our environment to version 9.0.0.19 some Spaces don't publish, when we click on button "1-Click Publish" nothing happens and no error is shown on Service Center.
Please help us.

Hi Marcel,

Can you check if there is any error popup on the "Development - " tab? I've seen once an error appear there by mistake.
It keeps happening consistently even after restarting Service Studio?

You can also do "Help" -> "Submit Feedback" and submit an issue with it.
It sends logging information from Service Studio so we can check if something was logged there.

Regards,
João Rosado
Hi João,
Thank you for your reply, no error appear in "Development -" tab and we submit a feedback to outsystems via Service Studio.
Hi Marcel,

I checked the submitted information and the error is related a size limit on the request, either on the server or in some proxy in between.
The method that is failing has a low request size, so it should not be hitting any limit.

I recommend you to check the IIS limits on your server by following the steps in the checklist under
Tuning Internet Information Services
- Configure upload size limits


If all looks ok there, I would suggest you to try openning Service Studio locally in the server machine and try from there, to see if it can be a proxy problem.

Regards,
João Rosado
Hi João,
Thank you again, but I followed the checklist and the values are configured to the maximum recommended, then I tried to publish locally on server, however, the same occurred.

Regards,
Marcel
Hi Marcel,

Googling a bit for the error I got to this topic that may be related: http://forums.iis.net/t/1169257.aspx?Request+Entity+Too+large+413+error+

Can you try disabling your https binding on your server just to see if it's also related to ssl.
Just temporarily changing the port on the https binding should do the trick and make Service Studio fallback to http (just make sure you restart Service Studio).




What else did you change in your platform server (apart from upgrading the version) ?

Regards,
João Rosado
Hi João,
Thank you very much, that is it!
We disabled the https and worked.

Problem solved

Regards,
Marcel
Well, I don't really consider it a solution since the https is necessary for security reasons.
I suggest you to try to understand what caused the problem to start appearing now or even contact OutSystems support to try to correctly fix the problem.

(note after turning https on again it may require the Service Studio preferences to be cleared to defaults to be able to replicate the problem again, since it has a cache information saying he the server does not support https)

Regards,
João Rosado