[IdP] iDP not redirecting to original URL after sign-in

[IdP] iDP not redirecting to original URL after sign-in

  
Forge Component
(18)
Published on 4 Dec (9 days ago) by Telmo Martins
18 votes
Published on 4 Dec (9 days ago) by Telmo Martins
Hello,
I’m trying to get the iDP Connector component working so we can do single sign-in for our Apps. We have a Microsoft Federated Server 3.0 in the Azure cloud which should be backward compatible with the Federated Server version 2.0 that this component expects. When I attempt to log into the APP_C test app, it does redirect me to the federated server login page, but then I am not redirected back to the original app. 
Is that normal behaviour of the example app?
How do I make it redirect back to the correct page?

<(G)> wrote:Any luck

I am facing the same issue and getting error after it gets SAML goes to idp/sso.aspx, redirects to Home.aspx and eventually goes to /customhandler/notfound.aspx. Upon looking at logs, i see following, however the XML validation seems fine.

Root element is missing.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
   at System.Xml.XmlDocument.Load(XmlReader reader)
   at System.Xml.XmlDocument.LoadXml(String xml)
   at OutSystems.NssSAML_Utils.CssSAML_Utils.MssSAML_Response(String ssSAML_Response, String ssSAML_Cert, String ssSAML_Issuer, RLAttributeRecordList ssSAML_AttributeStatement, Boolean ssIsSAMLEncryptedAssertion, Byte[] ssSAML_Assertion_KeyStore, String ssSAML_Assertion_KeyStorePassword, Boolean ssDebug_ReturnAllAttributes, RCValidationRecord& ssValidation, RCDataRecord& ssData)
   at ssIdP.RssExtensionSAML_Utils.MssSAML_Response(HeContext heContext, String inParamSAML_Response, String inParamSAML_Cert, String inParamSAML_Issuer, RecordList inParamSAML_AttributeStatement, Boolean inParamIsSAMLEncryptedAssertion, Byte[] inParamSAML_Assertion_KeyStore, String inParamSAML_Assertion_KeyStorePassword, Boolean inParamDebug_ReturnAllAttributes, IRecord& outParamValidation, IRecord& outParamData)


Hello,
I’m trying to get the iDP Connector component working so we can do single sign-in for our Apps. We have a Microsoft Federated Server 3.0 in the Azure cloud which should be backward compatible with the Federated Server version 2.0 that this component expects. When I attempt to log into the APP_C test app, it does redirect me to the federated server login page, but then I am not redirected back to the original app.
Is that normal behaviour of the example app?
How do I make it redirect back to the correct page?