Problems trying to create a database connection on the cloud platformn

Problems trying to create a database connection on the cloud platformn

  
Connection String test failed: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

Im having problems traying to create a database connection on the cloud platform. The secure connection(VPN Tunel) was configured, remote connection on the server is allowed y Im sure that put the server name correctly. 

Any help? Please

From the error message you are getting I would suspect that there is a connectivity problem. For example, the firewall on your SQL Server may be closed for connections comming from the IPs in the OutSystems PaaS side.

If this doesn't explain the issue, we might need to look deeper into it and to do that you should contact our support team. You can do this in LifeTime by clicking the "ask for help from support" link.
i have the same problem 
me too.
Any Solutions?
This problem is a communication problem between the machine hosting the platform and the database server. It's not something that can be fixed just on the platform side.

You need to check connectivity between the two servers, specifically if the platform server can connect to the database server on the port being used (usually 1433).

This is the solution for this problem.
Hi Ricardo Silva,

I have the same issue. I am installing on-premise in a secure environment. Windows firewall is off for traffic within the domain. I can logon my SQL Server DB using the SQL Server Management console.

Any idea?
Henri

Hi Henry when you said you could log in with SQL Server Management you did it on your machine or server in question? To simulate correctly the problem try to login using SQL Server Management from server.
Hi Alexandre,

I did the installation fresh today of SQL Server 2014 with RDP on the server. Also the SQL Server Management console is installed on the server itself. All installation work is done using one and the same windows domain account.
To check authorization in SQL server I tried manually to create a table with two columns in the outsystems database. That worked fine. The account I use is member of the administrator group and should be able to logon as a service (like mentioned in the setup html document I follow.

Thanks,
  Henri
Hi Henri you said that the Management Console is installed on the same server where SQL Server are installed. Try installing the Management Server in Outsystems platform server and try to connect from there using it. I ask early apologize if this has already tested.
Hi Alexandre,

It is indead a complete 1 server (localhost) party. Outsystems and Database are on the same (virtual) server. Windows2012 R2.
No worry you are proposing stuff already tested. I am just trying to find a connection point where it went wrong. As far as I can see I have a all lights green, but the configuration tool just refuses to connect. and it does not give a very detailed error. This technical stuff should cost 5 minutes if it goes right. But if it does not work as described...it cost me whole afternoon (I am in Europe). I do not have time in the project plan to spend another day finding the needle in the haystack.

Thanks,
 Henri

Hello Henri as new suggestion through SQL Management verify that no longer has the patterns created accounts Outsystems and remove them and try again.