LDAP connection

  
Has anyone used the LDAP module in the forge sucessfully?  As a first test I need to connect to this directory (http://drupal.gatech.edu/handbook/public-ldap-server) and am not having much luck with the forge component.  Note that we will probably be connecting to one or two LDAP directories (this one is no password, the other will be) to get user information, not for authentication hence wanting to use the forge component vs the built in LDAP verification.
I believe we use that component internally with success :)

Have you tried the demo? Are you getting any errors? If so, can you show the errors to us, they'll probably provide hints on the problem and a better direction on how to fix it.
Ricardo,

First off thank you for any help you can provide to help us get this working!

Well, I guess there are a couple of issues.  The first being that I have pretty much no experience LDAP so I am not sure if I have the correct world view of how it should work.  The second being that there is no documentation for the LDAP module on the forge whatsoever.

In overview what I want to do for this test is to connecto to this server (http://drupal.gatech.edu/handbook/public-ldap-server) and somehow I pass it a user id and then I am able to get information out of that directory.  I have set up some remote database connections already so I understand how that works but not sure of exactly what will happen, or what the order of events are, for getting information out of the LDAP directory.
It seems to me that the LDAP extension was made thinking mostly of an Active Directory as the recipient and does not seem prepared to do anonymous binds.

I have tried configuring it on my personal and ended up simply getting "bad username or password".


Is this public LDAP server supposed to be accessible from the outside?

I have been trying to connect to it and browse and all that using various tools (LDAPDemo eSpace, .NET code, JXplorer) without success.

Do you know if there's any issue?
Ricardo,

I am not sure if its open outside the GT network or not.  Can you run me through how you would set up the ldap forge component so I could try it myself?
Ok,

I'm not sure how this would work out, but here's what I was trying to do.

First off, I'm using a slightly altered version of the LDAP component (which you can find in attachment).

1) the LDAP extension actions will always try anonymous binds if the username is empty
2) the LDAPDemo eSpace has 500 characters on the Path variable instead of 50 (I was reaching the limit)
3) the LDAPDemo eSpace accepts an empty username and password (to allow for anonymous binds)

I'm not 100% sure the changes to the LDAP extension work as expected, the only LDAP server I had to test was yours and that wasn't working out so well :)

So, to test it out:

a) fill the path with: LDAP://whitepages.gatech.edu/dc=whitepages,dc=gatech,dc=edu
b) go to the Search page 
/LDAPDemo/Search_List.aspx and just hit Search, see what I get.

I'm currently getting an error, but I am also not able to use an LDAP browser on your LDAP server without errors, so I'm not exactly sure what this means, and my LDAP troubleshooting skills are probably tending towards 0/10 :)