Create user with full control on Lifetime & ServiceCenter

Create user with full control on Lifetime & ServiceCenter

  
Hi everyone,

Although this is not recommended, I would like to know how can I create a user with full control on Lifetime and ServiceCenter - but I want to do it directly from database, with SQL Management Studio in this case. What are the exact tables I should insert into?

Thanks
Hi Tiago,

Can you explain your use case?
Lifetime have a Web Service API to do those operations: http://www.outsystems.com/help/SErviceStudio/9.0/APIs/LifeTimeServices/Overview_of_LifeTime_Services_API.htm

If you need it to recover lost access to an environment you will have to ask OutSystems Support, as we won't be able to help you here.


Edit: oops had pasted the wrong link

Regards,
João Rosado
Hi João,

It seems that when configuring Users and Roles on Lifetime, at a certain stage we tested Active Directory which was successful, but it then gave us options to configure users, with a dropdown choice which I think had Lifetime selected and another button which was wrongly clicked that had some kind of confirmation action... This is what I think happened.
The fact is that now there is no user with permissions to connect to Lifetime or ServiceCenter. This is the best I can explain it...
From what I see in the docs, this was on Lifetime, when configuring "Authentication" under "Users & Roles".

The "Test Authentication Provider" was successful but then some button was clicked that activated this option and now when connecting to Lifetime we get "Invalid Login" message.
Hi again,

Thanks for your help João. Problem solved now.

Here is the description of what was the situation. When configuring Lifetime, on Authentication menu we tested ADAuthProvider, which was successful. But then, by mistake clicked that last button "Save Authentication Settings" without any configuration of the plugin in environments. There was no confirmation message when button was clicked and we just lost access to Lifetime/ServiceCenter, because there were no users from Active Directory with permissions on Lifetime Users.


Problem was solved by changing one table (OSSYS_AUTHPROVIDER) by changing ISACTIVE from 1 to 0. This reverts the activation done on previous screen/image.



Cheers