[Offline Apps] Navigating between wizardsteps

[Offline Apps] Navigating between wizardsteps

  
Forge Component
(25)
Published on 2015-11-19 by OutSystems Labs
25 votes
Published on 2015-11-19 by OutSystems Labs
Hello,


I'm using the wizard from the SilkUI Framework. I have an application which gives the user the possibility to chose between products. The next step in the wizard shows what the user has chosen.

I'm trying to implement the possibility to do this offline. My first wizardstep is working offline perfectly, but when i want to go to the next wizardstep to  show the product the user has chosen, it doesn't work. It always shows me an empty table.

In my rest screen, i used an aggregate GetProductById. Using the filter i filter the product the the user has chosen. (Product.ID = Session.ChosenProduct). Afterwards i use the convertRecordListToJson and the download widget with the right information.

For some reason, the result is always empty. It seems like my filter isn't working. 
Is it because i'm using only one screen for the whole wizard and using ajax refreshes to update the content( using visibilty true or false on containers)?

Greetings,

Niels


Niels Favreau wrote:
Is it because i'm using only one screen for the whole wizard and using ajax refreshes to update the content( using visibilty true or false on containers)?
 It sure is! When offline, the AJAX efreshes won't be executed at all. To implement a wizard that works offline you should probaly make each step of the wizard in a separate screen. You may want to check the Inspections app, for a working example.

Cheers,
João
 
João Pedro Abreu wrote:
Niels Favreau wrote:
Is it because i'm using only one screen for the whole wizard and using ajax refreshes to update the content( using visibilty true or false on containers)?
 It sure is! When offline, the AJAX efreshes won't be executed at all. To implement a wizard that works offline you should probaly make each step of the wizard in a separate screen. You may want to check the Inspections app, for a working example.

Cheers,
João
 
 Thank you for your response.

I tried using diffrent screens but now i have an other problem.
When i link to the detailscreen of the chosen product i always get a negative attribute. (packid=-204562899)
I checked my first screen where it listss all the products in the table, and indeed all the ID's  of the listed products are nagetive numbers.

What could be the problem?
 
Niels Favreau wrote:
I tried using diffrent screens but now i have an other problem.
When i link to the detailscreen of the chosen product i always get a negative attribute. (packid=-204562899)
I checked my first screen where it listss all the products in the table, and indeed all the ID's  of the listed products are negative numbers.

What could be the problem?
 The most likely cause for this is missing the "offline" extended property on the link itself. It is needed both on the expression and on the link.